Bug 238601 - Crash Reading Endadget Feed
Crash Reading Endadget Feed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 240650 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 14:55 EDT by Daryll
Modified: 2007-12-02 09:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-02 09:53:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryll 2007-05-01 14:55:09 EDT
Using version 1.2.10 from Fedora 7 Extras, I also packaged 1.2.13 from the
source using a slightly modified 1.2.10 RPM spec, but the problem persists with
either version.

Reading the engadget feed:
http://www.engadget.com/rss.xml 

Consistently causes liferea to crash under Fedora 7 test 4.

Please see:
https://sourceforge.net/tracker/?func=detail&atid=581684&aid=1709612&group_id=87005

The crash appears to come deep inside the gtkHTML2 widget.
The recommendation from Lars is to use Gecko as the renderer instead.
Comment 1 Brian Pepple 2007-05-06 15:21:56 EDT
Hmm, I've been trying to reproduce this with the gtkhtml2 widget, but have been
unable to with 1.2.13.  Did Lars recommendation work for you?
Comment 2 Daryll 2007-05-06 16:20:22 EDT
No everything has crashed for me so far. I have rebuilt using 1.2.13 and
gtkhtml2 and it crashed. I have no switched the renderer to Gecko and tried
that. (Not sure how to build it that way)

If you're running F7t4 and it isn't crashing, maybe it's something horked on my
system. The only feeds that crash it for me are engadget and engadget mobile
(strangely engadget HD works). I exported my feed list, removed my .liferea-1.2
directory, and then reloaded my feeds.

From the crash dump I posted on Lars' bugzilla, it appears to be some font
problem deep in gtkhtml2. I'm stumped.

Comment 3 Brian Pepple 2007-05-06 16:31:03 EDT
(In reply to comment #2)
> No everything has crashed for me so far. I have rebuilt using 1.2.13 and
> gtkhtml2 and it crashed. I have no switched the renderer to Gecko and tried
> that. (Not sure how to build it that way)

If you used my spec to build 1.2.13, you would have needed firefox-devel to
build it.  If so, pick the mozilla plugin under the Browser tab in Preferences.
 Then restart liferea and see if that helps.

BTW, are you running x86_64?

Comment 4 Daryll 2007-05-06 17:18:38 EDT
Well shucks. I did build it (1.2.13) with Mozilla support and sure enough when I
switch to that in the Browser tab, it doesn't crash on engadget. So that's a relief.

No not using x86_64

Here's the crash dump from GTKHTML2. Since I ran it from a console this time I
also got a really  suspicious warning message that I hadn't noticed before:


(liferea:4696): Pango-WARNING **: shape engine failure, expect ugly output. the
offending font is 'DejaVu LGC Sans Not-Rotated 0'

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208927584 (LWP 4696)]
---Type <return> to continue, or q <return> to quit---
0x00dce210 in pthread_mutex_lock () from /lib/libpthread.so.0
(gdb) where
#0  0x00dce210 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0x063e445f in ?? () from /usr/lib/libcairo.so.2
#2  0x063e47bb in ?? () from /usr/lib/libcairo.so.2
#3  0x063d4d17 in ?? () from /usr/lib/libcairo.so.2
#4  0x063d521d in cairo_scaled_font_text_extents () from /usr/lib/libcairo.so.2
#5  0x0755d1a0 in ?? () from /usr/lib/libpangocairo-1.0.so.0
#6  0x0755d525 in ?? () from /usr/lib/libpangocairo-1.0.so.0
#7  0x0755fd8d in ?? () from /usr/lib/libpangocairo-1.0.so.0
#8  0x07571cae in pango_font_get_glyph_extents ()
   from /usr/lib/libpango-1.0.so.0
#9  0x07579d11 in ?? () from /usr/lib/libpango-1.0.so.0
#10 0x07579a4a in ?? () from /usr/lib/libpango-1.0.so.0
#11 0x0758aba2 in pango_shape () from /usr/lib/libpango-1.0.so.0
#12 0x008b7436 in ?? () from /usr/lib/libgtkhtml-2.so.0
#13 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#14 0x008ad3c8 in html_line_box_add_inlines () from /usr/lib/libgtkhtml-2.so.0
#15 0x008b867f in ?? () from /usr/lib/libgtkhtml-2.so.0
#16 0x008b8ac9 in ?? () from /usr/lib/libgtkhtml-2.so.0
#17 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#18 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
#19 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#20 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#21 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
---Type <return> to continue, or q <return> to quit---
#22 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#23 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#24 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
#25 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#26 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#27 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
#28 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#29 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#30 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
#31 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#32 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#33 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
#34 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#35 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#36 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
#37 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#38 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#39 0x008aca68 in html_line_box_add_block () from /usr/lib/libgtkhtml-2.so.0
#40 0x008b8c71 in ?? () from /usr/lib/libgtkhtml-2.so.0
#41 0x008b07de in ?? () from /usr/lib/libgtkhtml-2.so.0
#42 0x008ae25e in html_box_relayout () from /usr/lib/libgtkhtml-2.so.0
#43 0x008ca97f in ?? () from /usr/lib/libgtkhtml-2.so.0
#44 0x0615e769 in g_cclosure_marshal_VOID__BOXED ()
---Type <return> to continue, or q <return> to quit---
   from /lib/libgobject-2.0.so.0
#45 0x06150589 in ?? () from /lib/libgobject-2.0.so.0
#46 0x06151e7d in g_closure_invoke () from /lib/libgobject-2.0.so.0
#47 0x061628ca in ?? () from /lib/libgobject-2.0.so.0
#48 0x06163957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#49 0x06163b19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#50 0x07b9fdaa in gtk_widget_size_allocate () from /usr/lib/libgtk-x11-2.0.so.0
#51 0x07adf3fb in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#52 0x0615e769 in g_cclosure_marshal_VOID__BOXED ()
   from /lib/libgobject-2.0.so.0
#53 0x06150589 in ?? () from /lib/libgobject-2.0.so.0
#54 0x0x061628ca in ?? () from /lib/libgobject-2.0.so.0
#56 0x06163957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#57 0x06163b19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#58 0x07b9fdaa in gtk_widget_size_allocate () from /usr/lib/libgtk-x11-2.0.so.0
#59 0x07b97ad0 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#60 0x0615e769 in g_cclosure_marshal_VOID__BOXED ()
   from /lib/libgobject-2.0.so.0
#61 0x06150589 in ?? () from /lib/libgobject-2.0.so.0
#62 0x06151d9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#63 0x061628ca in ?? () from /lib/libgobject-2.0.so.0
#64 0x06163957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#65 0x06163b19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#66 0x07b9fdaa in gtk_widget_size_allocate () from /usr/lib/libgtk-x11-2.0.so.0
#67 0x079ef55c in gtk_container_resize_children ()
   from /usr/lib/libgtk-x11-2.0.so.0
#68 0x079f1808 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#69 0x0615f0f9 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#70 0x06150589 in ?? () from /lib/libgobject-2.0.so.0
#71 0x06151d9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#72 0x06162a83 in ?? () from /lib/libgobject-2.0.so.0
#73 0x06163957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#74 0x06163b19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#75 0x079ef5f3 in gtk_container_check_resize ()
   from /usr/lib/libgtk-x11-2.0.so.0
#76 0x079ef673 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#77 0x060148c1 in ?? () from /lib/libglib-2.0.so.0
#78 0x06016622 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#79 0x060195ff in ?? () from /lib/libglib-2.0.so.0
#80 0x060199a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#81 0x07a806a4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#82 0x08086303 in main ()
(gdb) 


Comment 5 Brian Pepple 2007-05-19 10:01:09 EDT
*** Bug 240650 has been marked as a duplicate of this bug. ***
Comment 6 Brian Pepple 2007-12-01 18:16:45 EST
Are you still experiencing this in the 1.4.x branch?
Comment 7 Need Real Name 2007-12-02 05:52:27 EST
WFM
Comment 8 Brian Pepple 2007-12-02 09:53:15 EST
(In reply to comment #7)
> WFM

Ok.  I'll go ahead and mark as NOTABUG.  If this occurs again, please re-open
the bug.

Note You need to log in before you can comment on or make changes to this bug.