Bug 238608 - python-kaa-metadata doesn't obsolete mmpython 0.4.10
python-kaa-metadata doesn't obsolete mmpython 0.4.10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-kaa-metadata (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
Depends On: PPC64MissingDeps
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 15:23 EDT by Ville Skyttä
Modified: 2008-01-02 18:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 18:13:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-05-01 15:23:12 EDT
python-kaa-metadata obsoletes mmpython < 0.4.10, however mmpython 0.4.10 exists
(according to upstream, that'll be the last version) and packages are out there,
eg. in ATrpms, http://atrpms.net/dist/fc6/mmpython/

Should probably bump the versioning in the mmpython and python-mmpython
Obsoletes to eg. < 0.4.11.

Additionally, does kaa-metadata actually Provide a drop-in replacement for
mmpython?  If not, it shouldn't Provide it, just Obsolete.
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-3cfc1ea19d28975faad9d56f70a6ae55661d3c3d
Comment 1 Nicolas Chauvet (kwizart) 2007-05-01 17:12:23 EDT
I will bump the versionning indeed...

I think it provides such drop-in replacement:
%{_bindir}/mminfo is bundled both from mmpython and kaa-metadata
I wasn't using mmpython package but freevo uses kaa-metadata...

I think packages that was using mmpython can now uses python-kaa-metadata!
Do you encounter problems with such applications ?





Comment 2 Ville Skyttä 2007-05-01 17:44:24 EDT
I don't myself use mmpython or kaa-metadata for anything, but a quick inspection
tells me that it's not a drop-in replacement.

Software written in Python that uses these extensions is affected; with mmpython
you'd do something like "from mmpython import *" or "import mmpython", but that
doesn't work with kaa-metadata - with it one needs to do "from kaa.metadata
import *" or "import kaa.metadata" - and that doesn't work with mmpython.

If that's correct, they're not compatible and I think the Provides:
python-mmpython and Provides: mmpython should be removed.
Comment 3 Nicolas Chauvet (kwizart) 2007-05-01 18:37:57 EDT
That's mean that if i drop Provides: mmpython < %{version}-%{release}
Then when someone will install python-kaa-metadata it will also drop mmpython
and package that need mmpython (as you describe) will fails... 

So maybe it would be better to check if any updates are avaiable for packages to
link to kaa-metadata...

But i would think packages are using the mminfo python script in _bindir,
so nothing change from mmpython or kaa-metadata...

Anyway, python-kaa-metadata and mmpython cannot be installed together so i would  
say that there is a need to check:
- packages (mainly third part repo) that Requires mmpython
- How they need mmpython ( * by using mminfo : -> good
   * by importing mmpython in script :- > Bad for kaa-metadata compat with mmpython)
   |---> They is a need to check if upstream can provides an updated version
that use kaa-metadata first... (thinking on others solutions if needed...)



Comment 4 Nicolas Chauvet (kwizart) 2007-05-02 11:07:23 EDT
repoquery --whatrequires --alldeps mmpython --repoid=atrpms
didn't ouput anything - maybe there is some BR (i don't knwo how to check then...)

others main third part repo didn't seem to Requires it also...
Comment 5 Nicolas Chauvet (kwizart) 2007-05-05 08:07:22 EDT
I'm would like to rebuild it to obsolete mmpython 0.4.10
but it fails on libdvdread-devel for ppc64 (only for devel then)
Comment 6 Ville Skyttä 2007-05-05 13:51:31 EDT
(In reply to comment #4)
> repoquery --whatrequires --alldeps mmpython --repoid=atrpms
> didn't ouput anything - maybe there is some BR (i don't knwo how to check 
> then...)
> others main third part repo didn't seem to Requires it also...

Well, is there *any* reason to have the Provides: mmpython and Provides:
python-mmpython then, considering that they're kind of incorrect in the first
place?  They're still there in the specfiles in CVS.

(In reply to comment #5)
> I'm would like to rebuild it to obsolete mmpython 0.4.10
> but it fails on libdvdread-devel for ppc64 (only for devel then)

http://www.redhat.com/archives/fedora-maintainers/2007-May/msg00074.html
Comment 7 Nicolas Chauvet (kwizart) 2008-01-02 18:13:18 EST
Obsoleting mmpython isn't needed anymore in rawhide (Fn +2)
I plan to have them in EPEL4/5 soon ...

Note You need to log in before you can comment on or make changes to this bug.