Bug 238660 - Bonding methods have changed for RHEL 5, deployment guide needs to be updated.
Bonding methods have changed for RHEL 5, deployment guide needs to be updated.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Douglas Silas
Michael Hideo
: Documentation
: 471997 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 00:47 EDT by Norm Murray
Modified: 2016-06-17 17:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-06 18:28:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2007-05-02 00:47:23 EDT
Description of problem:

The RHEL5 Deployment guide references the old method of configuring bonding. 
This method was relevant in RHEL4 but is no longer works in RHEL 5.

The sample bonding configuration file now looks like:

sample channel bonding configuration file:

DEVICE=bond0
IPADDR=192.168.1.1
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
BONDING_OPTS="<bonding options>"


The sysconfig scripts supply the bonding module
options in the ifcfg-bondX file, it is not necessary to add additional
parameters to the /etc/modprobe.conf configuration file.



Version-Release number of selected component (if applicable):

Current Docs on website (
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Deployment_Guide-en-US/s1-networkscripts-interfaces.html#s2-networkscripts-interfaces-chan)
as of Wednesday, May 02 2007.


Additional info:

For more information about the options check out:
/usr/share/doc/iputils-*/README.bonding
Comment 1 Wade Mealing 2007-05-02 00:53:14 EDT
Also, the warning section below...

----
Important

Important aspects of the channel bonding interface are controlled through the
kernel module. For more information about controlling the bonding modules, refer
to Section 40.5.2, “The Channel Bonding Module”.

---


May wish to be taken out,

The BONDING_OPTS , being moved from the kernel module ( 
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Deployment_Guide-en-US/s1-modules-ethernet.html#s2-modules-bonding
)

Could be moved into this section. 

Comment 3 Don Domingo 2007-09-18 23:09:29 EDT
Wade,

lots of changes have gone in to RHEL5 Deployment Guide HEAD; this includes
several Bonding-related revisions.

please verify that the following changes are sufficient for this bug to be resolved:
https://engineering.redhat.com/docbot/en-US/Red_Hat_Enterprise_Linux/5.1.0/html/Deployment_Guide/s2-networkscripts-interfaces-eth0.html

once verified, i will have this latest build of the RHEL5.1 Deployment Guide
pushed to live and replace the current one. 
Comment 4 Michael Hideo 2007-10-22 22:49:45 EDT
Removing automation notification
Comment 8 Aron Griffis 2009-07-01 11:51:34 EDT
The particular problem mentioned in this bug, namely BONDING_OPTS, doesn't seem to have been fixed in the documentation.  http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Deployment_Guide-en-US/s3-modules-bonding-directives.html still instructs the user to put the bonding module directives in modules.conf
Comment 9 Andy Gospodarek 2009-07-06 09:25:15 EDT
Whoever can, please delete the entire section included on this page:

http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Deployment_Guide-en-US/s3-modules-bonding-directives.html
Comment 10 Douglas Silas 2009-09-10 18:18:51 EDT
*** Bug 471997 has been marked as a duplicate of this bug. ***
Comment 13 Douglas Silas 2010-02-27 23:05:41 EST
This bug's predecessor is bug 221423.

I have fixed this bug in the RHEL6 DG and sent Andy a request to review my modifications to the documentation. Once the instructions are finalized and verified, I will merge the fix into the RHEL5 DG.
Comment 14 Andy Gospodarek 2010-03-01 11:09:50 EST
Sounds great, Douglas.

I am reviewing your email and the draft notes right now.
Comment 15 Douglas Silas 2010-03-15 17:39:06 EDT
Fixed in RHEL5 DG, -r . Clarifications about modprobe.conf made in Network_Scripts.xml and Modules.xml. New instructions for testing bonds with sysfs written. Bonding module parameters section updated with additional params, formatted much more sensibly, and clarifications made (mode names inserted, for example). Changes verified by Andy; setting to ON_QA.
Comment 20 John Skeoch 2010-06-06 18:28:36 EDT
Verified Comment#9 Section removed.   Red_Hat_Enterprise_Linux-Deployment_Guide-5-web-en-US-4-19.el5

Note You need to log in before you can comment on or make changes to this bug.