Bug 238673 - Resume from suspend fails on Dell Latitude D505
Resume from suspend fails on Dell Latitude D505
Status: CLOSED DUPLICATE of bug 282871
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 04:00 EDT by Kaare Fiedler Christiansen
Modified: 2013-03-05 22:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 04:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaare Fiedler Christiansen 2007-05-02 04:00:20 EDT
Description of problem:

When doing suspend-to-ram on a Dell Latitude D505, it does not survive resume.
On startup it flashes caps lock and scroll lock, turns on the backlight on the
black screen, but otherwise does not respond at all. It does not respond on
pings. Hibernate works, though.

This is a regression from Fedora Core 6, where suspend worked like a charm!



Version-Release number of selected component (if applicable):

Fedora 7 test4, kernel version 2.6.21-1.3116fc7

How reproducible:

Always.

Steps to Reproduce:
1. Boot up Fedora 7
2. Close the lid, or choose suspend
3. Open the lid, or press power button
  
Actual results:

Non-functional system, flashing caps lock and scroll lock

Expected results:

Working system
Comment 1 cje 2007-05-23 08:56:42 EDT
have a look at http://people.freedesktop.org/~hughsient/quirk/ and see if any of
that helps :-)
Comment 2 Rex Dieter 2007-05-24 11:11:26 EDT
re-assigning to hal-info  (adding quirks helped for my d620, prolly will for you
too).
Comment 3 Kaare Fiedler Christiansen 2007-05-24 16:37:55 EDT
Okay, I've really spent some time trying to get this to work now.

I have suspend working, under certain conditions:

First, I have to unload the module 'uhci_hcd'. I've created the file
/etc/pm/config.d/unload_modules, with this content:

SUSPEND_MODULES="uhci_hcd"

This gave me the ability to resume from suspend without a kernel panic (the
kernel panic is what causes the Caps-lock LED to flash).

After that, everything worked except the display. It stayed solidly off with not
even the backlight turning on.

I then tried, to the best of my ability, any combination of the suggested video
quirks from http://people.freedesktop.org/~hughsient/quirk/
No luck.

This behaviour seems similar to what is reported in bug 240964.

My video card is a Intel Corporation 82852/855GM Integrated Graphics Device (rev
02). I was using the i810 driver, version xorg-x11-drv-i810-2.0.0-3.fc7.

So I tried to switch to the intel driver. This was not a painless process, and
it still doesn't work, I can only get it to work on my external monitor, but
with that driver, and the module uhci_hcd unloaded, SUSPEND/RESUME WORKS!

Now, why do I need to unload uhci_hcd, and how do I debug it? Should I report it
as a separate issue?

Why can I not get video to resume, using the i810 driver? How do I debug it?
Should I report it as a separate issue?
Comment 4 Kaare Fiedler Christiansen 2007-07-20 08:54:17 EDT
I'm unsure which update fixed it, but now suspend/resume works with the i810
driver too, provided I blacklist uhci_hcd and give the quirk
power_management.quirk.vbe_post. During the weekend I will generate and send the
patch for the Dell Latitude D505.
Comment 5 Bug Zapper 2008-04-03 20:25:43 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Patrice Dumas 2008-04-15 04:43:24 EDT
It seems to me to be a duplicate of 282871.
(The other bug was filled more recently, but I just closed it).

Re-open if you think it is not true.

*** This bug has been marked as a duplicate of 282871 ***

Note You need to log in before you can comment on or make changes to this bug.