Bug 282871 - dell d505 suspend from ram video needs vbetool
Summary: dell d505 suspend from ram video needs vbetool
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal-info
Version: 8
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
: 238673 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-07 18:04 UTC by Patrice Dumas
Modified: 2013-03-06 03:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-15 08:36:27 UTC
Type: ---


Attachments (Terms of Use)
lspci output (1.73 KB, text/plain)
2007-09-07 18:06 UTC, Patrice Dumas
no flags Details

Description Patrice Dumas 2007-09-07 18:04:53 UTC
Description of problem:

When suspending on ram, video doesn't show up when restarting.
Using
vbetool post
restart the video, however.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2007-09-07 18:06:28 UTC
Created attachment 190251 [details]
lspci output

Comment 2 Till Maas 2007-09-24 18:33:03 UTC
Information of needed quirks is managed in hal-info, to create a patch, please
follow: http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html

You may need the information from:
lshal | egrep "(system.hardware.(product|vendor|version)|smbios.bios.version)"


Comment 3 Bug Zapper 2008-04-04 13:47:34 UTC
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 4 Patrice Dumas 2008-04-04 13:54:53 UTC
I don't know if it is still valid, since suspending now is broken, but there is
no reason why it should have changed.

Comment 5 Till Maas 2008-04-04 15:53:29 UTC
(In reply to comment #4)
> I don't know if it is still valid, since suspending now is broken, but there is
> no reason why it should have changed.

This cannot be fixed without the input from someone who owns a dell d505 and follows
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html

Maybe it is enough when the output of
lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version)"
is posted.

Comment 6 Patrice Dumas 2008-04-15 08:36:27 UTC
It seems to be fixed now. D505 appears in the quirk files, and I tested with
pm-suspend that it suspends and come back fine.

Comment 7 Patrice Dumas 2008-04-15 08:40:17 UTC
It also worked with acpitool -S, so maybe the vbetool quirk is not needed anymore.

Comment 8 Patrice Dumas 2008-04-15 08:43:25 UTC
*** Bug 238673 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.