Bug 238688 - Starting dhcdbd:sh: nmblookup: command not found
Summary: Starting dhcdbd:sh: nmblookup: command not found
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdenetwork   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 238790 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 11:17 UTC by Davide Bolcioni
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-04 13:38:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Davide Bolcioni 2007-05-02 11:17:17 UTC
Description of problem: The dhcdbd uses nmblookup but does not find it on the 
KDE live CD


Version-Release number of selected component (if applicable):
dhcdbd-2.7-1.fc7

How reproducible: Always


Steps to Reproduce:
1. Boot the Fedora 7 test 4 live CD
2. Observe console messages
3.
  
Actual results:
Starting dhcdbd:sh: nmblookup: command not found

Expected results:
No error messages

Additional info:
I guess dhcdbd needs either to (a) only invoke nmblookup if it's there or (b) 
if it's really needed (odd, I have no need of SMB on a 15+ host network) 
introduce a dependency to bring it in.

Comment 1 David Cantrell 2007-05-02 15:13:10 UTC
Attach the script you are talking about.  dhcdbd has nothing to do with
nmblookup and it's not in the init script.

Comment 2 Davide Bolcioni 2007-05-03 10:08:41 UTC
Sorry, it was a case of "post hoc, ergo propter hoc" misattribution. The 
actual component involved is LISa, i.e. kdenetwork-3.5.6-3.fc7, which starts a 
few steps before dhcdbd in the KDE live image; this tricked me into believing 
it was actually dhcdbd triggering the behavior indirectly.

Some LISa binary blindly starts nmblookup without ever checking if it's 
actually there; the resulting error messages appear on the console, at fixed 
intervals. They are not visibile when running under X. This behavior can be 
turned off in /etc/lisarc or through the LISa panel in the Local Network 
Browsing panel of KDE's control center.

This turned out to be a cosmetic bug; the best bet for FC7 is probably to ship 
with recourse to nmblookup disabled in /etc/lisarc, as it is easily enabled in 
the GUI when needed.

Comment 3 Ngo Than 2007-05-04 13:38:21 UTC
it's now fixed in kdenetwork-3_5_6-4_fc7. Thanks for your report.

Comment 4 Sebastian Vahl 2007-05-16 14:29:36 UTC
*** Bug 238790 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.