Bug 238748 - SELinux is preventing /usr/sbin/ntpd (ntpd_t) "read" access to pipe:[9396] (firstboot_t).
SELinux is preventing /usr/sbin/ntpd (ntpd_t) "read" access to pipe:[9396] (f...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 15:34 EDT by Scott Bambrough
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0544
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:39:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Bambrough 2007-05-02 15:34:47 EDT
Summary
    SELinux is preventing /usr/sbin/ntpd (ntpd_t) "read" access to pipe:[9396]
    (firstboot_t).

Detailed Description
    SELinux denied access requested by /usr/sbin/ntpd. It is not expected that
    this access is required by /usr/sbin/ntpd and this access may signal an
    intrusion attempt. It is also possible that the specific version or
    configuration of the application is causing it to require additional access.
    Please file a http://bugzilla.redhat.com/bugzilla/enter_bug.cgi against this
    package.

Allowing Access
    Sometimes labeling problems can cause SELinux denials.  You could try to
    restore the default system file context for pipe:[9396], restorecon -v
    pipe:[9396]. There is currently no automatic way to allow this access.
    Instead, you can generate a local policy module to allow this access - see
    http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385 - or you can
    disable SELinux protection entirely for the application. Disabling SELinux
    protection is not recommended. Please file a
    http://bugzilla.redhat.com/bugzilla/enter_bug.cgi against this package.
    Changing the "ntpd_disable_trans" boolean to true will disable SELinux
    protection this application: "setsebool -P ntpd_disable_trans=1."

    The following command will allow this access:
    setsebool -P ntpd_disable_trans=1

Additional Information        

Source Context                system_u:system_r:ntpd_t
Target Context                system_u:system_r:firstboot_t
Target Objects                pipe:[9396] [ fifo_file ]
Affected RPM Packages         ntp-4.2.2p1-5.el5 [application]
Policy RPM                    selinux-policy-2.4.6-30.el5
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   plugins.disable_trans
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 2.6.18-8.el5 #1 SMP
                              Fri Jan 26 14:15:21 EST 2007 i686 athlon
Alert Count                   1
Line Numbers                  

Raw Audit Messages            

avc: denied { read } for comm="ntpd" dev=pipefs egid=0 euid=0
exe="/usr/sbin/ntpd" exit=0 fsgid=0 fsuid=0 gid=0 items=0 name="[8709]"
path="pipe:[9396]" pid=2581 scontext=system_u:system_r:ntpd_t:s0 sgid=0
subj=system_u:system_r:ntpd_t:s0 suid=0 tclass=fifo_file
tcontext=system_u:system_r:firstboot_t:s0 tty=(none) uid=0

Additional Information:

I get this installing Xandros Bridgeways on RHEL5 (original release, no
updates).  At this time the product installs a plugin to manage the time server
but it has not been executed as yet.  I have the timeserver enabled and running.
I don't believe this has anything to do with the product I'm installing however.

I am running in a VMware virtual machine on RHEL4 update 4.
Comment 1 Miroslav Lichvar 2007-05-03 04:34:02 EDT
Looks like a duplicate of bug #232756.
Comment 2 Daniel Walsh 2007-05-03 09:47:46 EDT
You can safely ignore this message.

It will be fixed in u1.

selinux-policy-2.4.6-68
Comment 3 RHEL Product and Program Management 2007-05-03 10:06:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2007-11-07 11:39:32 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0544.html

Note You need to log in before you can comment on or make changes to this bug.