Bug 238833 - Error: Device 0 not connected
Error: Device 0 not connected
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Berrange
:
: 288301 435332 (view as bug list)
Depends On:
Blocks: 449772
  Show dependency treegraph
 
Reported: 2007-05-03 04:54 EDT by Jan Pazdziora
Modified: 2009-01-20 16:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:15:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xend-debug.log (1.26 KB, text/plain)
2007-05-03 04:57 EDT, Jan Pazdziora
no flags Details
Ignore errors fetching SXPR from individual domains which are shutting down (909 bytes, patch)
2008-07-11 07:24 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Jan Pazdziora 2007-05-03 04:54:54 EDT
Description of problem:

I've done a series of "xm list" command in my shell, vaiting for one Xen guest
to terminate. One of the calls ended up with

Error: Device 0 not connected

Version-Release number of selected component (if applicable):

xen-3.0.3-25.0.3.el5
kernel 2.6.18-6.el5xen

How reproducible:

Tried once.

Steps to Reproduce:
1. Have a couple of Xen guests running.
2. Run poweroff in one of them (even if I'm not sure this was the primary cause).
3. Run xm list a couple of times.
  
Actual results:

[root@hostel ~]# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      449     8 r-----  70493.3
rhel4-rhn500-28                           35      799     4 r-----     43.3
sputnik-prod                              19      799     1 r----- 957722.1
sputnik-stage                             17      799     4 -b---- 1421107.3
sputnik-webqa                             11      799     4 -b---- 1002823.3
[root@hostel ~]# xm list
Error: Device 0 not connected
Usage: xm list [options] [Domain, ...]

List information about all/some domains.
  -l, --long                     Output all VM details in SXP               
  --label                        Include security labels                    

[root@hostel ~]# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      449     8 r-----  70494.5
sputnik-prod                              19      799     1 r----- 957723.8
sputnik-stage                             17      799     4 r----- 1421111.4
sputnik-webqa                             11      799     4 -b---- 1002823.4
[root@hostel ~]# type xm
xm is hashed (/usr/sbin/xm)
[root@hostel ~]# rpm -qf /usr/sbin/xm
xen-3.0.3-25.0.3.el5

Note that the guest rhel4-rhn500-28 just terminated -- it is not the previous
output and is not on the next one.

The xm list commands were run like two seconds apart.

Expected results:

The dom0 is still there, so there should be some output for each xm list invocation.

Additional info:

This might and might not be related to
http://lists.xensource.com/archives/html/xen-bugs/2006-11/msg00022.html and
http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=807.

However, the 807 bug was closed with Resolution: WORKSFORME, which does not seem
to be the case for RHEL 5.
Comment 1 Jan Pazdziora 2007-05-03 04:57:14 EDT
Created attachment 154013 [details]
xend-debug.log

Here's the xend-debug.log. However, I cannot say for sure what (if any) parts
of that content are related to this problem and what was there already before I
got the error message.
Comment 2 Kaj J. Niemi 2007-07-31 08:59:07 EDT
I have seen similar. In my case I used RHEL5 GA dom0/guest, LVM dom0, one logical volume/guest 
system.

"xm list" gave the same error which I managed to circumvent by doing /sbin/service xend restart 
(resulting "xm list" would work for a while again).

What was more worrying was that the shutdowned guests did not show up anymore but from a LVM 
perspective were still holding the volumes (lvdisplay VG01, etc. showed that # open was 1 instead of 
zero). There was nothing in the xend.log or xend-debug.log at that time. After doing service xend 
restart xm destroy also refuses to destroy things not shown with xm list so there is really nothing else 
to do except restart dom0.

I am not sure if these are one and the same issue or if they just happen to coincide at the same time. :)

Comment 3 Brian Stein 2007-07-31 09:58:29 EDT
Please test with current 5.1 beta.
Comment 4 Jan Pazdziora 2007-08-13 08:55:07 EDT
I've tested now with Xen host running 2.6.18-38.el5xen and xen-3.0.3-35.el5. The
problem persists:

# xm shutdown rhel5 ; while true ; do xm list ; done
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    167.2
rhel5                                      1      299     1 -b----     21.6
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    167.5
rhel5                                      1      299     1 -b----     21.6
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    167.8
rhel5                                      1      299     1 -b----     21.6
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    168.1
rhel5                                      1      299     1 -b----     21.6
[...]
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    191.8
rhel5                                      1      299     1 r-----     28.4
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    192.4
rhel5                                      1      299     1 r-----     29.1
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    192.8
rhel5                                      1      299     1 r-----     29.4
Error: Device 0 not connected
Usage: xm list [options] [Domain, ...]

List information about all/some domains.
  -l, --long                     Output all VM details in SXP               
  --label                        Include security labels                    

Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    194.1
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    195.1
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1721     2 r-----    195.7

The (paravirtual guest) guest was running 2.6.18-8.el5xen but I assume guest's
kernel should not matter?
Comment 5 RHEL Product and Program Management 2007-10-16 00:01:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 RHEL Product and Program Management 2008-03-11 15:45:14 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 7 RHEL Product and Program Management 2008-06-02 16:37:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Daniel Berrange 2008-07-11 07:24:49 EDT
Created attachment 311563 [details]
Ignore errors fetching SXPR from individual domains which are shutting down
Comment 10 Daniel Berrange 2008-07-11 10:01:53 EDT
*** Bug 435332 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Berrange 2008-07-11 10:06:51 EDT
*** Bug 288301 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Berrange 2008-07-21 06:48:04 EDT
Built into xen-3.0.3-67.el5
Comment 15 errata-xmlrpc 2009-01-20 16:15:12 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0118.html

Note You need to log in before you can comment on or make changes to this bug.