Bug 23889 - Selecting 'restore default values' button in X configuration screen crashes anaconda
Selecting 'restore default values' button in X configuration screen crashes a...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Beta-3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 11:09 EST by Stelian Pop
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-18 13:01:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda traceback (4.58 KB, text/plain)
2001-01-12 11:09 EST, Stelian Pop
no flags Details

  None (edit)
Description Stelian Pop 2001-01-12 11:09:11 EST
Upon selection of 'restore default values' button in X configuration screen
anaconda crashes with a python exception (attached).
Comment 1 Stelian Pop 2001-01-12 11:09:51 EST
Created attachment 7505 [details]
Anaconda traceback
Comment 2 Glen Foster 2001-01-15 16:46:07 EST
This defect is considered MUST-FIX for Florence Beta-3
Comment 3 Michael Fulbright 2001-01-15 19:45:52 EST
Assigning to a developer.
Comment 4 Brent Fox 2001-01-17 13:03:38 EST
What did anaconda probe the video card and video memory as?
Comment 5 Stelian Pop 2001-01-17 17:16:50 EST
See bug #23887 for details (video card correctly recognized but video memory
misdetected).

Maybe the two bugs are closely related anyway...

Stelian.
Comment 6 Brent Fox 2001-01-17 21:12:12 EST
Actually, this bug is caused by bug #23887.  I think a bigger issue here is that
although I've added code for cards that report 64k less memory than they should,
this does not account for cards that, for example, report 64k too much memory. 
We need a more intelligent way of approximating the memory.

Then, there will be some cards that do not return anything useful at all for
memory.  In this case, maybe we should default to 1 Meg if it's a PCI or AGP
video card.
Comment 7 Brent Fox 2001-01-18 10:13:44 EST
Although bug #23887 has been resolved, the installer will still crash if there's
a card that cannot be probed for memory and the user clicks "Restore default
values"  This is basically a null pointer problem...there's nothing to reset to
and python crashes.  We should initialize the variable to something sensible and
this will not happen anymore.
Comment 8 Brent Fox 2001-01-18 13:01:40 EST
Fixed in the latest internal builds.  I've added some code to prevent tracebacks
from happening, even if the card's memory cannot be probed.  Brock, please
verify.

Note You need to log in before you can comment on or make changes to this bug.