Bug 238961 - xrandr 1.2 is causing overlapping xinerama geometry by default which messes up gnome-screensaver
xrandr 1.2 is causing overlapping xinerama geometry by default which messes u...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 239270 (view as bug list)
Depends On:
Blocks: FC7Blocker 530309
  Show dependency treegraph
 
Reported: 2007-05-04 04:01 EDT by Valent Turkovic
Modified: 2009-10-22 05:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 530309 (view as bug list)
Environment:
Last Closed: 2007-05-21 21:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of xdpyinfo (6.18 KB, text/plain)
2007-05-04 13:54 EDT, Valent Turkovic
no flags Details
system-auth file (844 bytes, application/octet-stream)
2007-05-04 13:56 EDT, Valent Turkovic
no flags Details
here is a strace log (11.25 KB, text/plain)
2007-05-07 10:29 EDT, Valent Turkovic
no flags Details
screensaver.log (15.15 KB, text/plain)
2007-05-15 09:49 EDT, Valent Turkovic
no flags Details
debug_messages (406 bytes, application/octet-stream)
2007-05-15 09:50 EDT, Valent Turkovic
no flags Details
Xorg.0.log with laptop only screen (94.08 KB, application/octet-stream)
2007-05-18 02:53 EDT, Valent Turkovic
no flags Details
maybe something like this (1.47 KB, patch)
2007-05-18 12:25 EDT, Ray Strode [halfline]
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 354663 None None None Never

  None (edit)
Description Valent Turkovic 2007-05-04 04:01:11 EDT
Description of problem:
I didn't know what happened, I was away from the laptop 15minutes and I return
with a blank window. I move my mouse in order to wake-up the desktop but nothing
happens! Then I try the keyboard and it seams to work... CAPS-LOCK works, ok so
it is not frozen. I try 1st console with CTRL-ALT-F1 and it works ok. Back to
GUI with CTRL-ALT-F7 - and it is stil a blank screen!!!

I tried restarting X a few times before I got what was wrong!

The screensaver runs, or just shows blank screen, but after it locks the screen
but when I move my mouse it doesn't show me a windows for ulocking it with my
password!

This makes desktop users who aren't aware of this to reboot the system because
it looks like it is frozen.

Trying a password to a blank screen works and then you get your desktop back.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Leave computer until it starts screensaver
2. Pres any key or move the mouse
3. Look at the blank screen
  
Actual results:
After moving the mouse while screensaver is tunning the screen blanks if it was
running some screensaver, if it was just in "blank screen" mode than nothing
happens.

Expected results:
I expect to be presented with an box in which I enter my password in order to
unlock the desktop.

Additional info:
Fedora Core 7 test 4 with all the updates up until 4th of May.
gnome-screensaver 2.18.0
Comment 1 Ray Strode [halfline] 2007-05-04 12:41:20 EDT
can you attach your /etc/pam.d/system-auth file please?

Also, the output of xdpyinfo would be useful
Comment 2 Valent Turkovic 2007-05-04 13:54:46 EDT
Created attachment 154147 [details]
output of xdpyinfo

output of xdpyinfo
Comment 3 Valent Turkovic 2007-05-04 13:56:17 EDT
Created attachment 154148 [details]
system-auth file

system-auth file
Comment 4 Ray Strode [halfline] 2007-05-04 20:38:30 EDT
and you switch to a virtual console, log in as root, and run 

strace -p $(/sbin/pidof gnome-screensaver)

and report the results?
Comment 5 Valent Turkovic 2007-05-07 10:29:17 EDT
Created attachment 154266 [details]
here is a strace log

I did 
strace -p $(/sbin/pidof gnome-screensaver)

as you said with external monitor attached, but log only fills up when I move
my mouse...
Comment 6 Valent Turkovic 2007-05-07 10:36:59 EDT
If you would like to see how it looks like go to my youtube video:
http://www.youtube.com/watch?v=Yc9bDbK9T_8
Comment 7 jmccann 2007-05-07 10:45:34 EDT
Looks like you are cloning the displays so it is probably this:
http://bugzilla.gnome.org/show_bug.cgi?id=354663
Comment 8 Valent Turkovic 2007-05-07 13:11:15 EDT
And I didn't config anything. This xorg.conf is self-made during the bootup I
guess because I at work I use external monitor and at home I don't.

Here is my xorg.conf with external monitor attached:


# cat /mnt/etc/X11/xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "Multihead layout"
        Screen      0  "Screen0" LeftOf "Screen1"
        Screen      1  "Screen1" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
        Option      "Xinerama" "off"
        Option      "Clone" "on"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "hr"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
        Identifier   "Monitor1"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1280x1024"
        HorizSync    31.5 - 67.0
        VertRefresh  50.0 - 75.0
        Option      "dpms"
EndSection

Section "Monitor"
        Identifier   "Monitor1"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1280x1024"
        HorizSync    31.5 - 67.0
        VertRefresh  50.0 - 75.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection

Section "Device"
        Identifier  "Videocard1"
        Driver      "vesa"
        VendorName  "Videocard Vendor"
        BoardName   "Intel Corporation Mobile 945GM/GMS, 943/940GML Express
Integrated Graphics Controller"
        BusID       "PCI:0:2:1"
        Screen      1
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen1"
        Device     "Videocard1"
        Monitor    "Monitor1"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x800"
        EndSubSection
EndSection
Comment 9 Valent Turkovic 2007-05-07 17:09:50 EDT
Ok, now I reverted back to the original fedora xorg.conf file and the bug is
still the same!

So I guess that it is not the same as the clone nVidia bug, but it has the same
manifestation.

Here is my present xorg.conf :

# cat /etc/X11/xorg.conf
# Xorg configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "hr"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Comment 10 Valent Turkovic 2007-05-11 03:49:00 EDT
If you need some more info please tell me and I'll do my best to give you
quality feedback.
Comment 11 Valent Turkovic 2007-05-15 03:42:54 EDT
I updated my system today with a bunch of new updates... and this bug is still
present. Do you need any more help from me in order to fix this bug?

Please look at the bug in this video I made:
http://www.youtube.com/watch?v=Yc9bDbK9T_8
Comment 12 Ray Strode [halfline] 2007-05-15 09:15:57 EDT
Hi Valent,

Can you add 

*.* /var/log/debug_messages

to /etc/syslog.conf and then (as root) run:

/sbin/service syslog restart

Then, can you bring up a terminal in your session and run
 
pkill gnome-screensaver
gnome-screensaver --no-daemon --debug >& screensaver.log

lock the screen, reproduce the problem and then attach

screensaver.log and /var/log/debug_messages to this report?
Comment 13 Valent Turkovic 2007-05-15 09:48:09 EDT
I did all you asked. Here are the attachements.
Comment 14 Valent Turkovic 2007-05-15 09:49:44 EDT
Created attachment 154735 [details]
screensaver.log

screensaver.log
Comment 15 Valent Turkovic 2007-05-15 09:50:08 EDT
Created attachment 154736 [details]
debug_messages

debug_messages
Comment 16 Ray Strode [halfline] 2007-05-15 10:22:40 EDT
So just to be clear, in the above log you:

1) Locked your screen
2) Wiggled your mouse and no dialog appeared
3) typed your password blind and got returned to your session

?
Comment 17 jmccann 2007-05-15 10:32:02 EDT
From your debug log:
[gs_manager_create_window] gs-manager.c:1343 (15:44:50):	 Creating 2 windows for
screen 0

This still seems like the xinerama bug I mentioned in comment #7.

The problem seems to be that gdk reports the wrong geometry/# of monitors and we
place two windows on top of one another.

You can try to test this using:
gtk+/tests/testxinerama

http://svn.gnome.org/viewcvs/gtk%2B/trunk/tests/testxinerama.c?view=markup
Comment 18 Ray Strode [halfline] 2007-05-15 10:48:11 EDT
Hey Jon, I didn't even see comment 7.  Thanks for the insight.

So this is probably some xrandr 1.2 wonkiness.

Valent, can you attach the output of

xrandr

?
Comment 19 Valent Turkovic 2007-05-16 04:20:53 EDT
replay to  Ray in comment 16:

1. yes
2. yes - but only when I have external monitor attached
3. yes

You can see all that in the youtube video I posted.
Comment 20 Valent Turkovic 2007-05-16 04:22:03 EDT
# xrandr 
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
VGA connected 1280x1024+0+0 (normal left inverted right) 376mm x 301mm
   1280x1024      60.0*+   75.0     59.9  
   1280x960       59.9  
   1152x864       75.0     74.8  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
LVDS connected 1280x800+0+0 (normal left inverted right) 331mm x 207mm
   1280x800       60.0*+   60.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
TV disconnected (normal left inverted right)
Comment 21 Ray Strode [halfline] 2007-05-16 10:09:22 EDT
yea, so xrandr is returning overlapping information about the heads...  We could
probably work around that in gnome-screensaver, but it's better to get this
fixed at the source I think.

Reassigning...
Comment 22 Ray Strode [halfline] 2007-05-16 18:16:59 EDT
Adding to blocker list because "can't see unlock dialog" is pretty bad.
Comment 23 Ray Strode [halfline] 2007-05-16 20:15:15 EDT
Hi Valent and Will,

Would one (or both) of you guys mind trying the packages at

http://koji.fedoraproject.org/koji/buildinfo?buildID=6692

? They add a workaround that I think may cope with this bug.
Comment 24 Valent Turkovic 2007-05-17 02:41:42 EDT
I don't mind, on the contrary I would love to test it but koji site is
unavailable. If you mail the files I need to install I'll test them.
Comment 25 Ray Strode [halfline] 2007-05-17 10:09:25 EDT
Adding Kristian to CC list at his request.
Comment 26 Ray Strode [halfline] 2007-05-17 10:10:06 EDT
Valent, it seems to be working now.
Comment 27 Kristian Høgsberg 2007-05-17 10:25:00 EDT
Hi Valent,

About the xrandr output you posted in comment #20: is that with or without the
external monitor attached?  Could you attach xrandr output with and without an
external monitor attached and your /var/log/Xorg.0.log after running those two
xrandr commands?  Thanks.
Comment 28 Adam Jackson 2007-05-17 12:35:35 EDT
(In reply to comment #21)
> yea, so xrandr is returning overlapping information about the heads...  We could
> probably work around that in gnome-screensaver, but it's better to get this
> fixed at the source I think.

What else is randr supposed to do?  If the heads are scanning out overlapping
areas, then that's what it has to report.
Comment 29 Will Woods 2007-05-17 13:55:21 EDT
Doesn't fix the problem for me - unlock dialog still appears on phantom
non-existent extra screen.
Comment 30 Ray Strode [halfline] 2007-05-17 15:13:31 EDT
So I talked to ajax a bit about this and apparently Xinerama has always
supported advertising overlapping information.  We just have to make
gnome-screensaver cope with it.
Comment 31 Ray Strode [halfline] 2007-05-17 15:43:14 EDT
Okay, one more try:

http://koji.fedoraproject.org/koji/buildinfo?buildID=6724
Comment 32 Valent Turkovic 2007-05-18 02:52:35 EDT
comment #20 was with connected external monitor.

here is xrandr only with laptop screen:

$ xrandr 
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right)
LVDS connected 1280x800+0+0 (normal left inverted right) 331mm x 207mm
   1280x800       60.0*+   60.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
TV disconnected (normal left inverted right)
Comment 33 Valent Turkovic 2007-05-18 02:53:57 EDT
Created attachment 154976 [details]
Xorg.0.log with laptop only screen

Xorg.0.log with laptop only screen
Comment 34 Valent Turkovic 2007-05-18 03:31:48 EDT
I installed gnome-screensaver-2.18.0-10.fc7.i386.rpm, rebooted the laptop and
here is the result:
http://www.youtube.com/watch?v=wCJmZ2XUhuw

the bug is still persists, and now you can see one thing also - GLSlideshow
screensaver shows it clearly on my video - the screens are overlapping.

and again xrandr output with external monitor connected as shown on video.

$ xrandr 
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
VGA connected 1280x1024+0+0 (normal left inverted right) 376mm x 301mm
   1280x1024      60.0*+   75.0     59.9  
   1280x960       59.9  
   1152x864       75.0     74.8  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
LVDS connected 1280x800+0+0 (normal left inverted right) 331mm x 207mm
   1280x800       60.0*+   60.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
TV disconnected (normal left inverted right)
Comment 35 Ray Strode [halfline] 2007-05-18 11:23:13 EDT
Very strange that raising the window didn't work...
Comment 36 jmccann 2007-05-18 11:30:28 EDT
Ray, do you know how I can view patches in koji?

I see them here:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=70926

But I can't see a download or view option.
Comment 37 Ray Strode [halfline] 2007-05-18 12:08:00 EDT
I don't think you can.  It's all in CVS though.

I guess the best thing to do, is the windows to never overlap each
other--subtract out overlapping regions.
Comment 38 Ray Strode [halfline] 2007-05-18 12:25:22 EDT
Created attachment 155012 [details]
maybe something like this
Comment 39 Ray Strode [halfline] 2007-05-18 13:07:42 EDT
Can you give this a try:

http://koji.fedoraproject.org/koji/getfile?taskID=10503&name=gnome-screensaver-2.18.0-11.fc7.i386.rpm
http://koji.fedoraproject.org/koji/getfile?taskID=10502&name=gnome-screensaver-2.18.0-11.fc7.x86_64.rpm

If these don't work, i'll have to setup a test environment rather than keep
shooting in the dark.
Comment 40 Will Woods 2007-05-18 15:21:10 EDT
Hooray! -11 works for me on x86_64.

Valent, can you confirm?
Comment 41 Valent Turkovic 2007-05-21 15:12:07 EDT
I was off for the weekend on a trip - just a sec. I'll boot my F7 and try it out...
Comment 42 Osma Ahvenlampi 2007-05-21 15:51:44 EDT
I can confirm this fixes the issue - I was just looking to file a report when I
found this ticket and the test rpm :)

One thing I might suggest, but probably really belongs upstream: it would be
smart to show the password dialog on each screen, just in case the one it would
be shown on has been disconnected (rather common with highly mobile laptops like
mine).
Comment 43 Valent Turkovic 2007-05-21 15:58:16 EDT
Works like a charm with i386 - great work!
Thank you.
Comment 44 Ray Strode [halfline] 2007-05-21 20:06:20 EDT
*** Bug 239270 has been marked as a duplicate of this bug. ***
Comment 45 Jeremy Katz 2007-05-21 21:28:34 EDT
-13 with this fix is built and tagged for tomorrow's rawhide
Comment 46 bugreports2005 2008-07-03 08:53:18 EDT
This bug is present in Red Hat Enterprise Linux 5.
Can it be reopened?
Comment 47 Will Woods 2008-07-03 09:29:55 EDT
No. If you want to open a bug for RHEL5, either clone this bug or create a new
one. Do not reopen this bug.
Comment 48 Ray Strode [halfline] 2008-07-03 09:31:10 EDT
bugreports2005, for RHEL support, please go to

https://www.redhat.com/apps/support/

Note You need to log in before you can comment on or make changes to this bug.