Bug 238991 - Anaconda does not occupy the whole screen.
Summary: Anaconda does not occupy the whole screen.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 237638 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-04 11:28 UTC by Debarshi Ray
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-05-04 14:30:28 UTC


Attachments (Terms of Use)

Description Debarshi Ray 2007-05-04 11:28:47 UTC
Description of problem:

While using the Fedora 7 test 4 i386 DVD for installation in graphical mode,
Anaconda does not occupy the entire screen area. Instead it appears as a
rectangle in the centre of the TFT monitor and the remaining is covered with
black and white dots.

A similar problem is encountered with Fedora Core 6 i386 DVD, when Anaconda
appears as a rectangle in the top left corner of the screen and the rest of the
space remains black.


Version-Release number of selected component (if applicable):

11.2.0.57-1


How reproducible:

Everytime.


Steps to Reproduce:

1. Insert the DVD and boot from it.
2. Select the graphical installation option from the menu and proceed.


Actual results:

The Anaconda window is a rectangular window in the centre of the screen and does
not cover the entire area.


Expected results:

The Anaconda window should have been maximized so as to cover the entire screen.


Additional info:

Here is my hardware profile on Smolt:
http://smolt.fedoraproject.org/show?UUID=0b11e791-0027-4f9d-a2bf-7d221a88c054

Comment 1 Jeremy Katz 2007-05-04 14:30:28 UTC
We try to start up in 800x600, but some LCDs really would rather run in their
native resolution.  We don't change the size of the anaconda window because
there are some things which are (unfortunately) a little dependent on the way
the screen is laid out and going to a larger window would break them.

Comment 2 Adam Jackson 2007-05-07 16:39:19 UTC
Except in this case, where the randr 1.2 code goes out of its way to ignore you
when you ask for 800x600.

Comment 3 Debarshi Ray 2007-05-07 16:51:38 UTC
> We try to start up in 800x600, but some LCDs really would rather run in their
> native resolution.

In older versions of Fedora (eg., FC2, FC3) Anaconda used to occupy the entire
screen. So was it so that in those days 800x600 was not a requirement for Anaconda?


Comment 4 Michael Wiktowy 2007-05-07 17:25:20 UTC
I suspect in those days xrandr didn't exist and some other more primitive and
less capable method of resolution switching was done (that happened to work in
your case but had complications in others). It looks like the bugs are getting
shaken out.

Comment 5 Adam Jackson 2007-05-21 21:27:18 UTC
*** Bug 237638 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.