Bug 239022 - opengl apps and desktop effects not playing well together
opengl apps and desktop effects not playing well together
Status: CLOSED DUPLICATE of bug 222262
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-04 09:54 EDT by Tom Horsley
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 12:07:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2007-05-04 09:54:41 EDT
Description of problem:

This is very fuzzy stuff which I'm just recording to get on record,
not sure if it is one bug or many or even if the ATI driver is the
right component to use.

Testing fc7t4 I have a gnome session up, desktop effects turned on,
and am downloading the latest updates via yumex. While waiting for
updates to download, I try to run the neverputt game. It seems to come
up for a second, then pops out of existance when the yumex app updates
its progress bars. I bring up a terminal and give it the focus rather
than yumex. I can now run neverputt without it disappearing almost
instantly. I can't explain why an "active" app having the focus when
I bring up neverputt would make neverputt crash, I merely observe that
it works better when a much more "passive" app has the focus. Having
gotten neverputt to stay up long enough to play with it, I now try
dragging it to a different location. It moves, but the original neverputt
window contents remains on the screen in the original location.
I start trying to play a game and almost immediately, the neverputt app
quits again, and this time (God knows why), it takes my USB mouse with it.
Keyboard (also USB) still works, but mouse is gone, plugging and unplugging
doesn't help. As soon as yumex finishes updating system, I Alt-TAB to the
terminal I have up and type reboot. Then submit this bugzilla :-)

Version-Release number of selected component (if applicable):

Hard to know exactly where any blame might lie, here is a selection
of possibly relevant packages from the system:

xorg-x11-drv-ati-6.6.3-2.fc7
xorg-x11-drivers-7.2-5.fc7
neverball-1.4.0-8.fc7
compiz-0.3.6-8.fc7
mesa-libGL-6.5.2-10.fc7
kernel-2.6.21-1.3116.fc7


How reproducible:

Didn't try this particular sequence again, but I've seen the window moving
problem before as well as neverputt disappearing. I never have these problems
with neverputt in a "normal" X session with no desktop effects turned on.

Steps to Reproduce:
1. see description
  
Actual results:


Expected results:


Additional info:

Hardware might be relevant here:

AMD Athlon 64 X2 4400+ dual core cpu, 2 gig memory
Sapphire Radeon X700 Pro PCIe video adaptor
BIOSTAR TForce4U socket 939 motherboard.
Comment 1 Adam Jackson 2007-05-08 12:07:03 EDT

*** This bug has been marked as a duplicate of 222262 ***

Note You need to log in before you can comment on or make changes to this bug.