Bug 239204 - Automount fails to recognize external USB hard disk in FC7 test4 --- Work around
Automount fails to recognize external USB hard disk in FC7 test4 --- Work around
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: autorun (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: HardwareEnablement
Depends On:
Blocks: 204396
  Show dependency treegraph
 
Reported: 2007-05-05 21:35 EDT by Leslie Satenstein
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-09 20:15:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
copy of dmesg. (32.00 KB, text/plain)
2007-05-06 18:55 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2007-05-05 21:35:37 EDT
Description of problem:

Insert flash drive, (sandisk)  automount functions and I have access.
Isert a formatted hard disk as external drive,(formatted ext3) and drive fails
to be mounted.

automount works with both and fc6.

tried it with current kernel   vmlinuz-2.6.20-1.3104.fc7


Version-Release number of selected component (if applicable):
 
autorun-3.20-1.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Leslie Satenstein 2007-05-06 18:55:43 EDT
Created attachment 154234 [details]
copy of dmesg.

copy of dmesg.	Refer to tail end about not recognizing the partition type for
the usb hard disk.
Comment 2 Leslie Satenstein 2007-05-07 17:47:18 EDT
My original problem was that I could plug my external hard drive to usb port
using FC7 system so that I could read/write data to it, but the drive was not
mounted. I could not mount it at all.

But this drive worked just fine with FC6.

=============

I tried, with fc6 to reformat the drive, and the drive was read/writable with
fc6, but not FC7.
 
But I did succeed.

Here is the work around to fix the problem. Perhaps step1 is not required.

While the disk cannot be auto-mounted, both logical volume manager (lvm) and
gparted can see it when either program is executed from FC7 test4.

step1: Boot fc7 test4.  Use logical volume manager (lvm) to initialize the
partition. (I get to see 232gig out of 250 and it removed a gparted error
message about a corrupt partition),  

step2: Using FC7 Gparted fc7 version, create the dos default label and then
format the hard disk selecting ext3. 

The disk is now mountable on FC7 and FC6. and I can read/write using either
operating linux.


NOTE.  Gparted from FC6 will not allow FC7 automount program to mount this disk
if step2 was done with GPARTED executing on FC6 my experience is that it will
not work.

Should this bug be transfered to gparted support?  I would hope that there
should be no difference in the execution of the fc6 and fc7 versions. 

Is the bug in the FC7 Automount code?



Comment 3 Leslie Satenstein 2007-05-09 20:15:48 EDT
Here is the results of further testing. (live use).  
When files are added to the /media/disk via a boot from fc6, the disk will
eventually not be recognized by fc6 automount.  Ergo, there is no way to
transfer files between fc6 and fc7, but the reverse is true.

In my view, this is a show stopper for FC7,  One cannot backup a drive onto a
USB hard disk suitably formatted and labeled.
Comment 4 Harald Hoyer 2007-05-29 05:11:30 EDT
dupe of bug #238385 ??
Comment 5 Leslie Satenstein 2007-05-29 22:40:16 EDT
Since I no longer have a problem.... what is the indication to mark....


Note You need to log in before you can comment on or make changes to this bug.