Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 23923 - xinetd not waiting for tftpd to finish
xinetd not waiting for tftpd to finish
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tftp (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 29788 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 16:43 EST by Need Real Name
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 16:43:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-12 16:43:09 EST
xinetd cannot wait for tftpd to finish the transfer because xinetd does a
select on a wait for process tftpd but tftpd does a fork() (version 0.15
was doing an execve()) and doesn't wait for its child (which does the
transfer). An 'strace -fp `cat /var/run/xinetd.pid`' shows the bug.

/etc/xinetd.d/tftp:
# default: off
# description: The tftp server serves files using the trivial file transfer
\
#	protocol.  The tftp protocol is often used to boot diskless \
#	workstations, download configuration files to network-aware printers, \
#	and to start the installation process for some operating systems.
service tftp
{
	socket_type		= dgram
	wait			= yes
	user			= nobody
	log_on_success		+= USERID
	log_on_failure 		+= USERID
	server			= /usr/sbin/in.tftpd
	server_args		= /tftpboot
#	disable			= yes
}
Comment 1 Jeff Johnson 2001-01-17 16:25:32 EST
FIxed in tftp-0.17-7. Thanks for noticing.
Comment 2 Helge Deller 2001-03-01 11:08:58 EST
*** Bug 29788 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.