Bug 29788 - tftp service deactivates because of looping
Summary: tftp service deactivates because of looping
Status: CLOSED DUPLICATE of bug 23923
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tftp   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Helge Deller
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-27 17:50 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 09:46:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-27 17:50:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


tftp-server-0.17-7.i386.rpm

xinetd reports error:
01/2/26@22:13:31 xinetd[29434]: ERROR: tftp service was deactivated 
because of looping
01/2/26@22:13:31 xinetd[29434]: WARNING: recv: Bad file descriptor (errno 
= 9)Yoy?Puy?Ypu?aoy?uGoyeoy?+Yoyooy?uyooy?

tftpd will not respond any further until xinetd is restarted.



Reproducible: Sometimes
Steps to Reproduce:
1. upgrade tftpd tftp-server-0.17-7.i386.rpm
2. enable xinetd logging via editing /etc/rc.d/init.d/xinetd script
     daemon xinetd -filelog /var/log/xinetd.log -reuse -
pidfile /var/run/xinetd.pid
3. configure tftpd via editing /etc/xinet.d/tftp
      server_args       = -cs /var/tftpd
4. upload files around 1 megabyte or above several times (let tftpd create 
file)
5. tftp responded correctly with many small files, but tftping larger 
files produced looping crash
	

Actual Results:  tftpd stops with looping errror
tftpd does not die during the file transfer though....
tftpd will not respond again until xinetd is restarted


Expected Results:  tftpd should have exited normally and waited for future 
connections

Comment 1 Pekka Savola 2001-02-28 09:09:37 UTC
tftp package in 7.0 incorrectly specified 'wait=no' in xinetd.d/tftp.  This should be 'wait=yes'.  This has been corrected in later
package versions.  If you change only that setting, will the problem go away?

Comment 2 Helge Deller 2001-03-01 16:09:02 UTC

*** This bug has been marked as a duplicate of 23923 ***


Note You need to log in before you can comment on or make changes to this bug.