Bug 23946 - NVdriver: unresolved symbol irq_stat
NVdriver: unresolved symbol irq_stat
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
: 24094 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-13 01:29 EST by jimcable
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-16 12:59:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jimcable 2001-01-13 01:29:28 EST
STEPS TO GENERATE SYMPTOM
1) download source:
ftp1.detonator.nvidia.com/pub/drivers/english/XFree86_40/0.9-5/NVIDIA_kernel-0.9-5.tar.gz

2) download patch:
http://www.linuxgames.com/misc/patch-2.4.0-PR

3)untar the source tarball:
tar xvzf NVIDIA_kernel-0.9-5.tar.gz
cd NVIDIA_kernel

4) apply the patch:
patch -p1 <~/patch-2.4.0-PR

5) make the module:
make

ERROR REPORTED:
   text	   data	    bss	    dec	    hex	filename
 391021	  26944	     40	 418005	  660d5	NVdriver
depmod: *** Unresolved symbols in /lib/modules/2.4.0-0.43.12/video/NVdriver
/lib/modules/2.4.0-0.43.12/video/NVdriver: unresolved symbol irq_stat
/lib/modules/2.4.0-0.43.12/video/NVdriver: insmod
/lib/modules/2.4.0-0.43.12/video/NVdriver failed
/lib/modules/2.4.0-0.43.12/video/NVdriver: insmod NVdriver failed
make: *** [package-install] Error 255

COMMENTS:
This error does not occur when using pristine kernel sources:
http://www.kernel.org/pub/linux/kernel/v2.4/linux-2.4.0.tar.gz
instead of kernel rpms:
http://csociety-ftp.ecn.purdue.edu/pub/redhat/rawhide/i386/RedHat/RPMS/kernel*-2.4.0-0.43.12.i686.rpm
Comment 1 Sammy 2001-01-16 12:59:26 EST
See my solution on but 24094....
Comment 2 Mike A. Harris 2002-02-11 02:56:29 EST
Patches for anything at all, are intended to apply to a given source
base, and this includes any Nvidia patches, or patches from other sources
for anything.  When the base source code changes, in this case the kernel,
if the parts of code change that a given patch is patching, then that patch
may not apply cleanly anymore.  This looks like what you're seeing here.

This is not a bug in the kernel.  When the kernel changes, whoever makes
patches for the kernel, needs to update their patches so they apply to
the newer kernel, in this case, Nvidia would be the ones who have to fix
this problem.
Comment 3 Mike A. Harris 2002-02-11 02:57:47 EST
*** Bug 24094 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.