This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 239585 - F8 CD/DVD hangs with message "Ready"
F8 CD/DVD hangs with message "Ready"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
8
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Jones
Brian Brock
: Reopened
: 251724 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-09 13:37 EDT by Steve
Modified: 2008-11-26 12:36 EST (History)
21 users (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 12:36:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch for testing (1.04 KB, patch)
2007-09-14 12:01 EDT, H. Peter Anvin
no flags Details | Diff
Output of lspci (7.31 KB, text/plain)
2007-09-20 03:09 EDT, Barry Clarke
no flags Details
output of asus av700-x with one sata-drive (2.56 MB, image/jpeg)
2007-09-20 03:41 EDT, Steve
no flags Details

  None (edit)
Description Steve 2007-05-09 13:37:36 EDT
Description of problem:
FC7 test4 CD/DVD hangs with message "Ready" after loading the kernel. The
installer starts if i unplug the sata-drive! Also no problem with pata-drives.
I've this on several boards.

Version-Release number of selected component (if applicable):
Any FC6.93 (i386) boot media

How reproducible:


Steps to Reproduce:
1. Use any FC6.93 boot media
2. Boot
3. System hangs with message: "Ready"
  
Actual results:


Expected results:
Media should boot normally.

Additional info:
Comment 1 Steve 2007-05-09 13:50:03 EDT
Boards are all ASUS-A7V600(-X).
Comment 2 Steve 2007-05-13 04:46:56 EDT
All FC6 (Zod) media are booting correctly.
Comment 3 Steve 2007-05-28 17:01:31 EDT
If have exactly the same issue with the images from Fedora-7-RC2.
Comment 4 Steve 2007-05-31 04:44:28 EDT
There is a way to install Fedora 7 on ASUS-A7V600(-X) (maybe other) boards with
any sata drives connected. USE AT YOUR OWN RISK!!!

Unplug any sata drives. When the kernel is loading, plug in (hotplug) the drive.
Then everything is working. ;o)
Comment 5 Axon 2007-06-02 12:07:42 EDT
This bug seems to be extant for the install on the final release F7 i386 DVD ISO.
Comment 6 Axon 2007-06-02 12:21:49 EDT
Please see here:

http://forums.fedoraforum.org/showthread.php?p=801772#post801772
Comment 7 Steve 2007-06-02 12:34:22 EDT
Please feel free to reopen this bug. But i don't know whether it make sense,
becauce fc7 is released...
Comment 8 Axon 2007-06-03 06:31:36 EDT
I don't seem to have the permission to do that,
Comment 9 Wes Bachman 2007-06-11 15:00:37 EDT
I am seeing this same problem, attempting to boot the Fedora 7 installation DVD
on a Dell Dimension 5150.  The kernel load completes the "Ready." prompt and
just hangs.  Can this bug be reopened, or is there another entry tracking this bug?
Comment 10 Barry Clarke 2007-06-20 18:19:18 EDT
Just adding myself as a 'me too'. Similiar system to Wes previously; Dell
Dimension 5150, BIOS rev A05, pentium D 945, 2GB ram; Fedora 7 x64 DVD install.
System halts at 'ready' (caps lock light stops working which is my usual 'dead
machine' test). I have 2* SATA disks holding an FC6 install that I'm looking to
upgrade, so unplugging them is not an option. Some forum posts have indicated
playing around with grub options maxcpus=1 and/or clocksource=acpi_pm may help
so I'll give that a pop. I'll also try a http install and post back.
Any information I can provide to help?
Comment 11 Mike LeVan 2007-06-23 17:42:12 EDT
Hey,

Same exact problem as others. Dell Dimension 5150, one SATA drive. FC6 installed
no problem.

Comment 12 Rahul Sundaram 2007-06-23 18:35:32 EDT
Looks like this bug report got closed by the original bug report but folks are
still facing this issue in Fedora 7. Reopening. 
Comment 13 Barry Clarke 2007-07-05 05:33:52 EDT
Just to report that after walking through several BIOS revisions on by dell 
5150, (I am now on A07) I managed to get the install going by creating a USB 
boot disk using the boot.img provided on the F7 download page. Booting from 
this allows me proceed to the install/upgrade from DVD. I haven't actually had 
time to /do/ the upgrade yet, but this seems a viable workaround.

Barry
Comment 14 Kris Linville 2007-07-10 10:38:09 EDT
Having the same issue on a Dell Dimension E510 running only a single SATA drive.

Have tried both the F7 Live CD and the F7 DVD on two different E510 machines.


Kris Linville
RHCT
Comment 15 Tom Cross 2007-08-02 16:25:33 EDT
I had this same problem with f7 install media not booting on my Dell Dimension
5150.  I was asked to try "edd=skipmbr" on the kernel command line.  I tried it
and now the kernel is booting and installing f7.
Comment 16 Barry Clarke 2007-08-05 12:36:59 EDT
Just to report my system was successfully upgraded over the weekend using the
'boot from USB stick, install from DVD' method. I have some dependencies to work
out and had to poke grub a little to get a clean boot but I'm pretty sure that's
my fault.

Barry
Comment 17 Steve 2007-08-08 13:49:38 EDT
the problem is not fixed in fedora 8 test 1.
Comment 18 Steve 2007-08-18 03:20:07 EDT
adding "edd=skipmbr" to the kernel command line is working with fedora 8 test 1.
should it be a standard value?
Comment 19 Chuck Ebbert 2007-08-20 15:09:20 EDT
This bug should be fixed in upstream kernels now, and in the latest
rawhide/development kernels.
Comment 20 Steve 2007-09-13 16:52:14 EDT
the problem seems not fixed in fedora 8 test 2. with adding "edd=skipmbr" to the
kernel command line the kernel is booting. it should be fixed asap!
Comment 21 Chuck Ebbert 2007-09-13 19:00:16 EDT
(In reply to comment #20)
> the problem seems not fixed in fedora 8 test 2. with adding "edd=skipmbr" to the
> kernel command line the kernel is booting. it should be fixed asap!

Bug is still there? What kind of hardware is it?

Comment 22 Chuck Ebbert 2007-09-13 19:03:28 EDT
(In reply to comment #20)
> the problem seems not fixed in fedora 8 test 2. with adding "edd=skipmbr" to the
> kernel command line the kernel is booting. it should be fixed asap!

...and does the latest rawhide boot.iso print anything at all? There is new
debug code in there now.
Comment 23 Steve 2007-09-14 02:50:32 EDT
It is also not booting with the latest boot.iso (09/13/2007). 

the new debug code is: 
..............................................
Ready.
Booting: ABCDEFGHIJ

The hardware: 
ASUS-A7V600(-X)
SONY DVD RW DRU-700a
SEAGATE SATA ST3160828AS
Comment 24 Dennis Björklund 2007-09-14 08:42:33 EDT
I also get the same output:

  Booting: ABCDEFGHIJ

on my Dell Dimension 5150
Comment 25 Chuck Ebbert 2007-09-14 10:57:38 EDT
*** Bug 251724 has been marked as a duplicate of this bug. ***
Comment 26 H. Peter Anvin 2007-09-14 12:01:38 EDT
Created attachment 195991 [details]
Proposed patch for testing

Can someone please try the attached patch and see if it fixes the problem?
Comment 27 Chuck Ebbert 2007-09-14 17:01:48 EDT
kernel with the patch is building now; people with this problem please test
tomorrow's rawhide boot disks.
Comment 28 Steve 2007-09-15 03:18:57 EDT
the kernel from boot.iso (09/14/2007) does also not boot with the same output:

..............................................
Ready.
Booting: ABCDEFGHIJ
Comment 29 Knute Johnson 2007-09-15 12:18:06 EDT
(In reply to comment #28)
> the kernel from boot.iso (09/14/2007) does also not boot with the same output:
> 
> ..............................................
> Ready.
> Booting: ABCDEFGHIJ

(In reply to comment #27)
> kernel with the patch is building now; people with this problem please test
> tomorrow's rawhide boot disks.

I downloaded the 20070915 boot.iso this morning and tried it.  I got,

ABCDEFHIJ0   that's a zero on the end and no G this time

My computer is a Dell Dimension XPS T600.  A PIII, 600Mhz.  I don't have a SATA
drive but I do have a VESA video card (I think).
Comment 30 Knute Johnson 2007-09-15 12:35:22 EDT
(In reply to comment #29)

I looked at your code for the patch.  I know I don't know what is going on there
but it looks like you iterating over the drives?  Could having a CD, Floppy and
a ZIP drive cause a problem?
Comment 31 Steve 2007-09-15 12:39:18 EDT
same here, the kernel from boot.iso (09/15/2007) does also not boot with the output:

..............................................
Ready.
Booting: ABCDEFGHIJ0
Comment 32 Steve 2007-09-15 12:43:08 EDT
(In reply to comment #31)
> same here, the kernel from boot.iso (09/15/2007) does also not boot with the
output:
> 
> ..............................................
> Ready.
> Booting: ABCDEFGHIJ0

sorry, G is also missing here.
Comment 33 Dennis Björklund 2007-09-17 02:37:25 EDT
Exactly the same on Dell Dimension 5150. ABCDEFHIJ0 (and no G).

One thing the Dell Dimension 5150 have is a memory card reader that can read
lots of different kinds of memory cards. No memory card inserted. It's probably
not related to the boot problem, but I thought i'd mention it anyway just in case.

/Dennis
Comment 34 Chuck Ebbert 2007-09-17 10:39:52 EDT
(In reply to comment #33)
> Exactly the same on Dell Dimension 5150. ABCDEFHIJ0 (and no G).
> 

Failed on disk 0
Comment 35 H. Peter Anvin 2007-09-17 12:22:17 EDT
Help urgently needed: I need at least one volunteer with a failing system to do
tight-loop debugging on this problem, which means wait for me to make an image,
test something out, report back, and repeat.  We're already past rc6, so the
issue is extremely urgent.  Please email me directly.
Comment 36 Matt Domsch 2007-09-17 22:23:51 EDT
Rez Kabir - critical Fedora / kernel.org bug with EDD on Dimension 5150 and
E510.  Please assist in reproducing and debugging ASAP.
Thanks,
Matt
Comment 37 Chuck Ebbert 2007-09-19 15:42:23 EDT
The latest rawhide boot disk has extended debugging added for this problem. Can
someone please test it?
Comment 38 Barry Clarke 2007-09-19 19:55:30 EDT
using 
download.fedora.redhat.com/linux/development/x86_64/os/images/boot.iso
(DaT 19/Sep/2007, MD5 23a40911550ddbc21ebfeac33f1b92be). Reboot into this and I
get the following:
*very* briefly see F1/F2/F3 boot options, then get into the Grub menu. At this
point I lose keyboard input, something I hadn't noticed before (I am not
renowned for observation skills to be fair). The grub menu timer continues to
count down and autoselects 'Install/Upgrade existing system' after 60 seconds.
System displays:
loading vmlinuz...
loading initrd.img...
ready
booting ABCDEFHJ
Then follows some debug stuff. It's late, it's been a long week, and I almost
certainly will introduce typos, so I've posted some grainy cellphone pics here:
http://barry.freeshell.org/top.jpg
http://barry.freeshell.org/bot.jpg

I'll type these up tomorrow.
Let me know what else I can try. I suppose the obvious is to strip all
extraneous hardware out and give that a pop.

cheers
Comment 39 Dennis Björklund 2007-09-20 02:07:30 EDT
Dell Dimension 5150:

Ready.
Booting: ABCDEFHIJ
Device 8f80: calling Int 13 Fn 0x4100 ...
 result: ax=3000 bx=aa55 cx=5 dx=80
Calling Int 13 Fn 0x4800 with buffer @8f7e ...
 result: ax=0 dx=80
Calling Int 13 Fn 0x0800 ...
 result: ax=0 bx=5 cx=feff dx=fe02 di=0
Calling Int 13 Fn 0x0201 with buffer @4600 ...

Then I waited a couple of minutes to see if there would come any more output,
bit it didn't.

No problem with keyboard. But I have access to another Dell computer at work (a
fairly new E520) where the keyboard doesn't work in grub in FC7 (and it didn't
work with this boot disk either). That computer however isn't mine and only run
windows so I've not looked much at it. This is another bug however. Time to
search for it in bugzilla and cc to it as well. One issue in each bug report!
Comment 40 Barry Clarke 2007-09-20 03:09:09 EDT
Created attachment 200511 [details]
Output of lspci

lspci -v output from an affected 5150.
Comment 41 Barry Clarke 2007-09-20 03:18:11 EDT
I've transcribed the pics I took last night now I've had sleep and coffee:
+--------------------------------------------+
Device 8f80: calling int 13 fn 0x4100 ...
 result: ax=2100 bx=aa55 cx=1 dx=80
calling int 13 fn 0x4800 with buffer @8f6a ...
 result: ax=0 dx=80
calling int 13 fn 0x0800 ...
 result: ax=0 bx=1 cx=e7e0 dx=103 di=0
calling Int 13 Fn 0x201 with buffer @4600 ...
 result: ax=0 bx=4600 cx=1 dx=80

Device 3681: calling Int 13 Fn 0x4100 ...
 result: ax=3000 bx=aa55 cx=5 dx=81
Calling Int 13 Fn 0x4800 with buffer @8f6a ...
 result: ax=0 dx=81
Calling Int 13 Fn 0x0800 ...
 result: ax=0 bx=5 cx=feff dx=fe03 di=0
Calling Int 13 Fn 0x201 with buffer @4600 ...
+--------------------------------------------+
I have two SATA disks (0 & 1). With:
disk 0 only - boot fails
disk 1 only - boot fails
disk 0 in disk 1's place - boot fails
disk 1 in disk 0's place - boot fails
disk 0 and disk 1 out - boots fine, to the prompt for install media.

Need to get to work, but I'll try with ide & maybe scsi disks later this evening
and see what happens.

Re the keyboard - Dennis is most likely correct, but I thought I'd mention it as
it feels like an I/O thing. the kbd works fine before booting (so I can select a
boot media) and, with no disks, after (so I can select a language). 
Comment 42 Steve 2007-09-20 03:41:56 EDT
Created attachment 200531 [details]
output of asus av700-x with one sata-drive
Comment 43 H. Peter Anvin 2007-09-20 16:59:02 EDT
It turns out that this isn't a kernel issue at all.  Rather, it is an
interaction between ISOLINUX (specifically, the ISOLINUX menu system) and the
BIOS.  If one holds down the Shift key to bring up the ISOLINUX prompt and
launches the kernel from there, this bug isn't triggered.

Most likely this is a BIOS bug, but it could be a SYSLINUX bug, and even if it
is a BIOS bug, it might be possible to work around it in SYSLINUX.

I have a system from Dell now which exhibits the problem, so I can start to look
at it.

In the meantime, this bug should be reassigned from kernel to syslinux.
Comment 44 Barry Clarke 2007-09-21 02:58:53 EDT
Heh. I didn't know you could do that. This allows me to boot my 5150 directly 
from the F7 x64 DVD I originally had problems with, as well as the last 3 
rawhide boot ISOs. 
Comment 45 H. Peter Anvin 2007-09-21 19:38:47 EDT
Bug identified and resolved.  The fix is in syslinux 3.52-pre9, which hopefully
will be released as 3.52 official in the next few days.
Comment 46 Dennis Björklund 2007-09-22 01:51:39 EDT
So we should wait for that before we try a new boot image? Or is the fix
included in rawhide now before the official 3.52 fix?
Comment 47 Knute Johnson 2007-09-22 13:07:12 EDT
(In reply to comment #43)
Thanks very much.  I've managed to load F7 (I had the DVD) on my computer with
no problems.  I'm sure that F8 will have no problems now.
Comment 48 Dennis Björklund 2007-09-24 11:23:28 EDT
I tried the boot.img from todays rawhide and it still didn't work. Was it
supposed to work now?
Comment 49 Knute Johnson 2007-09-25 00:09:25 EDT
(In reply to comment #48)
> I tried the boot.img from todays rawhide and it still didn't work. Was it
> supposed to work now?

I imagine it is going to take a while.  Have you got it running by pressing the
SHIFT key?
Comment 50 Dennis Björklund 2007-09-25 07:39:50 EDT
Yes, it does work using the SHIFT key.

I just wanted to make sure the fix get into fedora 8. The test 3 freeze is
today. It would be nice to have a test 3 that work.
Comment 51 Dennis Björklund 2007-10-01 01:49:33 EDT
This still doesn't work in rawhide so I guess it will not work in test3 and then
there is a big risk it wont work in fedora 8.

Current rawhide still output the debug stuff (ABCDEF..)
Comment 52 Adam Pribyl 2007-10-03 05:14:14 EDT
This should really be in F8, I have also several users complaining about that
and I was not able to explain this.
Comment 53 Jeremy Katz 2007-10-03 13:20:43 EDT
Added the patch for syslinux-3.36-6 (updating to syslinux-3.52 at this point is
pretty risky).  Can those experiencing problems test out the boot.iso from
tomorrow's rawhide and see if it fixes the problem?
Comment 54 Steve 2007-10-04 06:21:00 EDT
i find it unfortunate to see that it is also not working in f8test3. i hope
really it will be fixed in fedora 8. you cannot say all the users to hold down
the shift-key.

current debug-output is:

..............................................
Ready.
Booting: ABCDEFHIJ
Comment 55 Adam Pribyl 2007-10-04 06:44:46 EDT
As Jeremy Katz wrote yesterday - try rawhide boot.iso from, the syslinux should
be patched there - and this is not for all users, just a subset with certain
configuration.
Comment 56 Steve 2007-10-04 07:23:21 EDT
The boot.iso (03-Oct-2007 05:25) from the development-tree prints exactly the
same output as in f8test3 on the ASUS-A7V600(-X) board:

..............................................
Ready.
Booting: ABCDEFHIJ
Comment 57 Dennis Björklund 2007-10-05 01:58:43 EDT
Didn't we get a new boot.iso yesterday? The file on the mirrors is from before
Jeremy Katz added the patch. I'd love to try this to make sure fedora 8 work on
my dell computers without hassle.
Comment 58 Jeremy Katz 2007-10-05 10:12:13 EDT
Sorry, yesterday's rawhide blew up during the compose.  Today's is there and has
the updated isolinux bits.  And I've also gone ahead and grabbed it and put it
up at http://katzj.fedorapeople.org/boot-20071005.iso

[katzj@aglarond ~]$ sha1sum boot.iso 
a9c72fb8f66775be95a542c3cb3735a39ccd7038  boot.iso
Comment 59 Steve 2007-10-05 10:34:19 EDT
(In reply to comment #58)
> Sorry, yesterday's rawhide blew up during the compose.  Today's is there and has
> the updated isolinux bits.  And I've also gone ahead and grabbed it and put it
> up at http://katzj.fedorapeople.org/boot-20071005.iso
> 
> [katzj@aglarond ~]$ sha1sum boot.iso 
> a9c72fb8f66775be95a542c3cb3735a39ccd7038  boot.iso
> 
Nope, same autput as before.
Comment 60 Dennis Björklund 2007-10-05 10:35:03 EDT
The new boot.iso didn't work I'm afraid. It also got stuck at ABCDEFHIJ.
Comment 61 Thanga Babu 2007-10-06 13:39:56 EDT
I am trying to install 

1. Core 7.92 x86_64
2. ACER-Aspire 5100-5674  Laptop
3. AMD Athlon X2 64

I am not sure if anyone posted it here. Installation comes up fine. After each
package installation I have to move the mouse/press some key to keep the
installation pick the next package. Otherwise it hangs in the same packages.

Thanks,
Thanga Babu.
Comment 62 Steve 2007-10-11 09:59:16 EDT
Why the problem in fc6 isn't there?
Comment 63 Will Woods 2007-10-24 11:55:46 EDT
Current rawhide boot media seems to work for all the machines we've tried. Can
you test with boot.iso from rawhide and confirm?
Comment 64 Steve 2007-10-24 12:21:44 EDT
Not successfully here:

..............................................
Ready.
Booting: ABCDEFHIJ
Comment 65 Dennis Björklund 2007-10-26 05:54:17 EDT
Doesn't work here either (Dell Dimension 5150).

Booting: ABCDEFHIJ
Comment 66 Knute Johnson 2007-10-27 14:14:05 EDT
(In reply to comment #65)

I just tried the 20071025 rawhide boot.iso and it doesn't work on my old Dell
PIII either.

Comment 67 Lamar Owen 2007-11-07 11:56:16 EST
Release F8 image does this on a Dell Precision 650 here.

Hardware: 1x 2.4GHz Xeon, HT enabled, 2GB RAM.  Adaptec 39160 dual channel U160
controller with five 36GB U160 drives.  DVD+/-RW Samsung drive.

Fedora 7 KDE Live CD booted fine with Dell PERC 3/DC RAID controller instead of
the Adaptec 39160, and with a CDRW drive instead of the DVDRW drive.  F7 KDE
Live CD hangs at Ready with 39160 and the DVDRW.

edd=skipmbr has no effect when booting to F8 DVD install.

Holding SHIFT down and entering 'linux' on the ISOLINUX command line still
hangs, whether booting from the boot.iso on the DVD or from the DVD itself.


Holding SHIFT down and entering 'linux edd=skipmbr' on the ISOLINUX command ling
hangs.

Replacing the DVDRW drive with the original CDRW; boot still hangs from boot.iso.

F7 KDE Live will not boot with the CDRW drive anymore, either.  I did a full KDE
LiveCD install yesterday with this machine, but with the Dell PERC 3/DC
controller instead of the Adaptec 39160. (I swapped the 39160 in to improve RAID
5 performance, to switch to software RAID; the PERC 3/DC performance in RAID 5
stinks).

Disabling the INT13h SCSI BIOS on both 39160 channels allows boot to proceed for
installer, F8 release DVD.

I had issues with some of the disks, so i can't verify that it booted after
installation, but that's how I got the installer to boot and start.
Comment 68 martin coker 2007-11-11 11:38:10 EST
I am unable to install FC8 on my Asrock AM2XLI-eSATA2 MB AMD64 3800 when sata
drive present I can install on pata no problem. FC6 is installed along with xp
on the sata drive works no problem. I just get ready then nothing else. 
However the install will run on the sata  in my Asrock  conroexfire -eSATA2
Interl E6300 dual. So i am confused here as to what is the problem. I believed
it to be a sata issue but havent a clue now.
Comment 69 Oscar Schultz 2007-11-15 02:14:56 EST
I have the same problem on a Dell E510 with one sata drive.
bug Report 242152 appears to contain a similar problem

The machine gets to the Ready prompt and hangs

Any suggestions would be a great help
I've tried acpi=off, apm=off, ide=nodma, i8042.nomux, nofb, and edd=skipmbr 
one at a time and in combinations. The mahines hangs at the ready.
I've tried holding the shift key and entering linux with no success.
Comment 70 Steve 2007-11-15 02:54:05 EST
I have no more ASUS-A7V600-X motherboard. So i cannot test any bootmedia anymore..
Comment 71 martin coker 2007-11-15 05:31:06 EST
I have managed to get FC8 installed on my Asrock AMD64 see my post above. I have
two hard drives Sata and Pata installed. All i needed to do was change the order
of the boot hard drive in bios making the Pata first and holding the shift key
down was able to get to the boot:prompt. Entered linux and away it went no
problem. A little editing of grub has enabled me to boot either to the XP on the
Sata drive or FC8 on the Pata. interestingly though the rescue disk x8664 will
not boot so still an issue here. Do not know if this should be logged as another
bug "FC8 rescue disk hangs with message"Ready""
Comment 72 clee 2007-11-16 04:27:11 EST
I see the same issue here on the F8 release AMD64 Live-DVD and Install-DVD images.

Holding down shift while ISOLINUX is loading, and then using 'vmlinuz0 initrd=initrd0.img 
root=CDLABEL=Fedora-8-Live-x86_64 rootfstype=iso9660 ro liveimg' to boot makes it work. I did not 
try edd=skipmbr.
Comment 73 Lamar Owen 2007-11-17 17:51:39 EST
Update on Dell Precision 650:
Once isntalled, reenabling the INT13h SCSI BIOS allows a bootable system.

System runs great after installation; just have to disable the SCSI BIOS before
booting the DVD.
Comment 74 Jan Kovacik 2007-11-22 07:20:47 EST
Component: pirut
Summary: TB2f66aac2 __init__.py:633:keyImportCallback:TypeError: not all
arguments converted during string formatting

Traceback (most recent call last):
  File "/usr/sbin/pup", line 406, in _apply
    output = self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 803, in
applyChanges
    self.checkSignatures(dlpkgs, mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 662, in
checkSignatures
    self.getKeyForPackage(po, fullaskcb = keyImportCallback)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 2177, in
getKeyForPackage
    "fingerprint": fingerprint, "timestamp": timestamp})
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 633, in
keyImportCallback
    "import this key?") %(po, userid, hexkeyid, keyurl)
TypeError: not all arguments converted during string formatting

Local variables in innermost frame:
d: <gtk.MessageDialog object at 0x1042f964 (GtkMessageDialog at 0x10485840)>
mainwin: <gtk.Window object at 0x9fd1dc4 (GtkWindow at 0xa01e0e0)>
userid: Fedora Project <fedora@redhat.com>
keyurl: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
keydict: {'timestamp': 1067294011, 'userid': 'Fedora Project
<fedora@redhat.com>', 'keyurl': 'file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora',
'fingerprint': <bound method public_key.fingerprint of <yum.pgpmsg.public_key
instance at 0x10413a4c>>, 'hexkeyid': '4F2A6FD2', 'po':
<yum.sqlitesack.YumAvailablePackageSqlite object at 0xdecc0cc>}
hexkeyid: 4F2A6FD2
po: slrn - 0.9.8.1pl1-5.20070716cvs.fc8.i386

Comment 75 martin coker 2007-12-04 19:21:03 EST
This is probably the wrong place but I believe is the same issue. I am unable to
install any updated kernel to my F886x64.Having installed using the procedure in
this bug. I am stuck the original release kernel. The install of new kernels
will not write to /boot/grub/grub.conf. I have manually added the details ( even
trying  to map the drives) but even though the images are installed it is not
possible to access either of the two additional kernels.
Also the rescue disk will not work even standing on the shift key.
Comment 76 martin coker 2007-12-05 08:30:18 EST
Developments are a foot. I think I have found it
using mkinitrd -f -v --fstab=/etc/fstab /boot/initrd-2.6.23.8-63.fc8.img
2.6.23.8-63.fc8
I get below

Looking for deps of module ehci-hcd
Looking for deps of module ohci-hcd
Looking for deps of module uhci-hcd
Looking for deps of module ext3: mbcache jbd
Looking for deps of module mbcache
Looking for deps of module jbd
Found root device sdb6 for LABEL=/
Looking for driver for device sdb6
Looking for deps of module scsi:t-0x00: scsi_mod sd_mod
Looking for deps of module scsi_mod
Looking for deps of module sd_mod: scsi_mod
Looking for deps of module scsi_wait_scan: scsi_mod
Looking for deps of module pci:v000010B9d00005288sv00001849sd00005288bc01sc06
i01: scsi_mod libata ahci scsi_mod libata ahci
etc

This is the wrong address it should be sda5 any one have an idea how I can force
this? sdb6 is an fc6 install on the sata drive. F8 is on pata/ide . root is at sda5.
Comment 77 martin coker 2007-12-05 09:09:35 EST
Well I have done it here is what to do

1. Enter bios and disable sata boot only to IDE save and exit to restart boot up

2 mkinitrd for the correct kernel  in terminal as root
su -
mkinitrd -v -f /boot/initrd-2.6.23.8-63.fc8.img  2.6.23.8-63.fc8 this gives
output as install  for the Kernel 2.6.3.8-63 goes on this then picks up the
correct root / in my case sda5

3. gedit  /boot/grub/grub.conf to add the the kernel details see my below
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/sda5
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
[B]title Fedora (2.6.23.8-63.fc8)
	root (hd0,0)
	kernel /vmlinuz-2.6.23.8-63.fc8 ro root=LABEL=/ rhgb quiet
	initrd /initrd-2.6.23.8-63.fc8.img[/B]
title Fedora (2.6.23.1-42.fc8)
	root (hd0,0)
	kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet
	initrd /initrd-2.6.23.1-42.fc8.img
title Windows XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

4. Restart and enter bios to reinstate sata and ahci save and exit

5  Then the grub options all work ok
Comment 78 Oscar Schultz 2007-12-14 03:24:22 EST
The method of holding down the shift key while booting from cd/dvd works for 
the Dell E510 (see comment 69 above). I entered vmlinuz initrd=initrd.img to 
boot enough to install. After the install I have been able to upgrade however 
I have had to pick small sets of packages to update and work through the 
various packages rather than do a mass update.
Thanks very much for the help.
Comment 79 Alexei Podtelezhnikov 2007-12-31 00:12:43 EST
Dell E510 Bios A07 intended for dual boot F8 / XP - same story.
Using comment 69 verbatim helps to proceed with installation, albeit with a 
few I/O warnings during boot. The resulting system boots and works flawlessly.
Comment 80 Chris Weyl 2008-02-03 14:55:28 EST
Dell E510 Bios A07, no dual boot (just Fedora), was able to (finally!) update
from FC-6 to F8 using edd=skipmbr.
Comment 81 Bob 2008-02-13 21:23:17 EST
Dell E510, Bios A05, no dual boot, 2X 320G IDE, 2X 160G SATA, EXT USB DVDRW,
shift key on boot, edd=skipmbr worked with FC 8 DVD install. 
Comment 82 Dennis Björklund 2008-02-15 04:44:07 EST
I tried the Fedora 9 Alpha live cd and this still doesn't work. It hang on Ready.
Comment 83 Dennis Björklund 2008-03-27 04:08:07 EDT
It worked!

The Fedora 9 Beta live cd boots on my computer now. Finally. I've not been able
to (without a workaround) boot any Fedora since Fedora 6.
Comment 84 Yijun Yuan 2008-11-10 21:52:14 EST
There is a same 5150 box which cannot boot F10 Preview, have not tried edd=skipmbr yet
Comment 85 Bug Zapper 2008-11-26 02:15:08 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 86 Jon Stanley 2008-11-26 12:36:21 EST
As this bug is in MODIFIED, Fedora believes that a fix has been committed that resolves the problem listed in this bug report.

If this is not the case, please re-open this report, noting the version of the package that you reproduced the bug against.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.