Bug 251724 - Boot fails at 'Ready'
Boot fails at 'Ready'
Status: CLOSED DUPLICATE of bug 239585
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 14:19 EDT by Knute Johnson
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 10:57:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Knute Johnson 2007-08-10 14:19:40 EDT
Description of problem:

F8T1 Live CD fails to boot on Dell PIII 256MB computer.  This computer ran
FC2-FC6 with no problems.  It had the same problem booting F7.  I tried using
the boot.iso from the DVD of F7 and it also failed in the same place.

Version-Release number of selected component (if applicable):

F8T1

How reproducible:

Very

Steps to Reproduce:
1. Turn on computer
2. Attempt to boot with live CD or F7 boot.iso
3.
  
Actual results:

Starts to boot and fails at 'Ready'.  All disk activity stops.

Expected results:

Successful boot

Additional info:
Comment 1 Pat Kane 2007-08-17 10:16:45 EDT
The F8T1 DVD does not install on my Dell Inspiron 8600
laptop (Service Tag: DC0Y441  BIOS: A14).
After choosing "Install" from the main menu I see the
following:

   Loading vmlinuz ............................
   Loading initrd.img .......................
   .....
   Ready.

then the system hangs.

I tried the F8T1 DVD on my Dell Dimension 1100 tower, the
verify of the media was good and the install went
okay.

Pat  (pekane52 at gmail)
---

P.S. I just installed the F7 DVD on the 8600 laptop without problems
Comment 2 William Lovaton 2007-08-23 16:10:41 EDT
I think I have the same problem on my new Desktop at work using Fedora 7.  I
installed it using a Live USB memory and the original 2.6.21 kernel worked fine.
 Now I updated the whole system with yum update and the 2.6.22.1-41.fc7 kernel
wont boot, it blocks  after uncompressing the kernel just before showing the
Nash thing at the very beginning.

[root@localhost ~]# lspci
00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated
Graphics Controller (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Contoller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #2 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface
Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE
Controller (rev 02)
3f:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5755 Gigabit
Ethernet PCI Express (rev 02)
Comment 3 Chuck Ebbert 2007-08-23 17:18:12 EDT
(In reply to comment #2)
> I think I have the same problem on my new Desktop at work using Fedora 7.  I
> installed it using a Live USB memory and the original 2.6.21 kernel worked fine.
>  Now I updated the whole system with yum update and the 2.6.22.1-41.fc7 kernel
> wont boot, it blocks  after uncompressing the kernel just before showing the
> Nash thing at the very beginning.
> 

This looks like a separate problem. It is for Fedora 7 not F8 Test1, and it at
least decompresses the kernel. File a new bug.
Comment 4 Knute Johnson 2007-09-08 12:49:21 EDT
I have tried the latest rawhide live CD, 20070904, and the 20070905 boot.iso and
the results are still the same.

There were some comments on the test list about a fix being in for this problem
but I have yet to get a confirmation.
Comment 5 Chuck Ebbert 2007-09-10 19:05:20 EDT
(In reply to comment #4)
> I have tried the latest rawhide live CD, 20070904, and the 20070905 boot.iso and
> the results are still the same.
> 

kernels 0.170 and up have boot debugging. Try one of those (should be in
20070911 rawhide.)
Comment 6 Knute Johnson 2007-09-13 21:17:35 EDT
(In reply to comment #5)
> kernels 0.170 and up have boot debugging. Try one of those (should be in
> 20070911 rawhide.)

I just downloaded rawhide boot.iso 20070913.  It prints the Ready and then:

Boot: ABCDEFGHIJ

and stops.  I don't know if that is good or bad but it is different :-).

Thanks.
Comment 7 Chuck Ebbert 2007-09-14 10:44:52 EDT
Okay, EDD is failing:

        putchar('J');
        query_edd();

Does it work with the kernel option "edd=off" or "edd=skipmbr"?
Comment 8 Chuck Ebbert 2007-09-14 10:46:51 EDT
And what kind of Dell system is if failing on?
Comment 9 Chuck Ebbert 2007-09-14 10:57:37 EDT
Dup of 239585, please report further info against that bug...

*** This bug has been marked as a duplicate of 239585 ***
Comment 10 Chuck Ebbert 2007-09-14 17:20:18 EDT
Tomorrow's rawhide contains a patch that hopefully fixes this. Please test and
report results against bug 239585.

Note You need to log in before you can comment on or make changes to this bug.