Bug 239672 - 'Select All' on a filtered list selects items outside of the filter
'Select All' on a filtered list selects items outside of the filter
Status: CLOSED DUPLICATE of bug 241070
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Red Hat Satellite QA List
Depends On:
  Show dependency treegraph
Reported: 2007-05-10 10:15 EDT by Máirín Duffy
Modified: 2007-10-23 22:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-20 11:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2007-05-10 10:15:47 EDT
When you filter say a list of systems, and click the 'select all' button,
systems outside of the filter (and that are not visible to the user within the
list pages returned by the filter) are added to set. Pretty much all systems in
the unfiltered list are added when the list is filtered. 

Tasks such as getting systems with a particular naming scheme into particular
system groups, or just creating on-the-fly system sets to perform work on, are
impossible to accomplish from the system list because of this behavior.

The checkbox in the upper left corner of the list does not provide the needed
functionality, because clicking that checkbox only selects all visible (on the
current page) systems, not all systems in the currently displayed list. (e.g.,
100-page list of 1,000 systems, filtered down to 20 pages of 200 systems. Click
on the upper-left corner. Following current behavior, that would only select the
10 systems available on page 1 of the 20 page list of 200 systems. Make sense?)


Scenario: Say I have a list of 1,000 systems, and I have let's say 200 systems
with the term 'wkstation' in their name. I need to do some work on systems in
this particular namespace, and only those systems. 

(1) I go to my system list. I get a 100-page list of 1,000 systems.

(2) I filter for 'wkstation' in that system list, and I get a 20-page list with
200 systems in it. 

(3) I hit the 'select all' button in the lower-left corner of the list-view 
because I want to add all of those 'wkstation' systems and put them in a system
group (or perhaps merely just want to work with them as a system set.) Only
those 200 systems will be added to my set.

(4) I then clear my set by hitting clear in the SSM bar, upper right.

(5) I then clear the filter by erasing the filter term and hitting the 'go' button.

(6) Now I see all 1,000 systems again. I click 'select all'. All 1,000 systems
are selected.
Comment 1 Brandon Perkins 2007-07-20 11:00:32 EDT
Duplicate of 241070.

*** This bug has been marked as a duplicate of 241070 ***

Note You need to log in before you can comment on or make changes to this bug.