Bug 241070 - 'select all' behaves unexpectedly when filter selected
Summary: 'select all' behaves unexpectedly when filter selected
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: 420
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
: 239672 (view as bug list)
Depends On:
Blocks: 456985 483555
TreeView+ depends on / blocked
 
Reported: 2007-05-23 21:00 UTC by K. Reid Wightman
Modified: 2009-09-10 20:21 UTC (History)
1 user (show)

Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 20:21:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description K. Reid Wightman 2007-05-23 21:00:38 UTC
Description of problem:

When installing packages on a system, 'select all' selects all packages in a
channel (instead of just those that match the filter pattern).

Version-Release number of selected component (if applicable):
4.2.1

How reproducible:

Very.  Steps below.

Steps to Reproduce:

1. Log in to satellite server
2. Choose a System that is registered with satellite.  
3. Choose Software -> Packages -> Install for that system within satellite.  
4. Filter packages by typing in a specific package group name (e.g. "emacs")
5. Click 'go'.  
6. Choose 'Select All'.

Actual results:

1,375 packages selected (for default RHEL5 install)

Expected results:

4 packages selected (emacs, emacs-el, emacs-nox, gnuplot-emacs)

Additional info:

This 'user interface bug' also affects RHN thru 5.01 (current public RHN release).

Comment 1 Jesus M. Rodriguez 2007-05-23 21:45:23 UTC
If you click the checkbox in the header of the checkbox column it will only
select the four.  Select All by design is to select all packages. Though I see
an argument for making it only select all "filtered" items.

Comment 2 K. Reid Wightman 2007-05-23 22:22:04 UTC
(In reply to comment #1)
> If you click the checkbox in the header of the checkbox column it will only
> select the four.  Select All by design is to select all packages. Though I see
> an argument for making it only select all "filtered" items.

Yah, I noticed the checkbox works after I submitted.  It definitely seems like
'select all' should do more than just the column checkbox though.  For example,
if you filter on a much larger set of packages (like the letter 'a' for a rhel4
system), you'll get >300 packages.  Clicking the checkbox only selects those
that are selected on-screen, meaning cycling through a lot of screens with the
view set to 20 packages each.  'Select All' would be a lot more natural there if
it selected all packages in a filtered set.

I can't answer for what every user would expect, I just know how I think it
'should' work ;-).  Thanks for listening in any case.

Comment 3 Brandon Perkins 2007-07-20 15:00:48 UTC
*** Bug 239672 has been marked as a duplicate of this bug. ***

Comment 4 Justin Sherrill 2007-11-28 14:02:26 UTC
fixed in the new list tag in rev 134258.

fixing in the old list tag....

Comment 5 Justin Sherrill 2007-11-28 15:06:52 UTC
sadly this doesn't look feasible to fix in the old list tag :/

On the upside, the new list tag is on the most popular pages, so most of the
really important things this will be fixed for (systems, groups, users)


Comment 6 wes hayutin 2007-12-12 14:04:19 UTC
new list tag not used on this page..
since the user can use the check boxes instead.. punting to 5.2

Comment 7 Justin Sherrill 2009-02-24 20:05:07 UTC
commit	78dba0f21dbc3adfd53000f249d519a5a1571df8

tree	2497ad23769090b422e2f520cc7086761ac5933b	tree | snapshot

parent	53558f4a163379411fedfb1b92de87be48709d65	commit | diff


That was a lot harder to fix the 2nd go around.

Comment 8 wes hayutin 2009-03-23 12:49:50 UTC
verified..

Comment 10 Brandon Perkins 2009-09-10 20:21:07 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html


Note You need to log in before you can comment on or make changes to this bug.