Bug 239682 - Status of Filtered Lists is not very visible
Summary: Status of Filtered Lists is not very visible
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 248643
TreeView+ depends on / blocked
 
Reported: 2007-05-10 15:06 UTC by Máirín Duffy
Modified: 2008-04-02 21:08 UTC (History)
0 users

Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 21:08:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of a filtered list in the current webui, with pointers to problems (50.13 KB, image/png)
2007-05-10 15:10 UTC, Máirín Duffy
no flags Details
suggested improvements (53.56 KB, image/png)
2007-05-10 16:10 UTC, Máirín Duffy
no flags Details

Description Máirín Duffy 2007-05-10 15:06:48 UTC
When a listview is filtered, it's not very visible or apparent that the list is
actually filtered:

(1) The only indication that a successful filter operation has occurred is that
the filter text is in the text box. You also don't know how the full size of the
list compared to the filtered version. Eg if filtering a 1,000 system list
returns 200, I'll know I have 200 systems visible but the 1,000 number isn't
anywhere on screen. If you don't know the full size of the list how can you even
tell it is filtered? :) (see attached screenshot.)

(2) Unsuccessful filtering attempts remove filtering controls and don't have any
mechanism to clear the unsuccessful filter (besides page reload) (see bug 239607)

(3) The only way to clear a filter it is to empty out the filter text box and
click the submit button.

PROPOSED USE CASE to fix this
=============================

Scenario: Say I have a list of 1,000 systems, and I have let's say 200 systems
with the term 'wkstation' in their name. I need to do some work on systems in
this particular namespace, and only those systems. 

(1) I go to my system list. I get a 100-page list of 1,000 systems.

(2) I filter for 'wkstation' in that system list, and I get a 20-page list with
200 systems in it. A list-info (or similar) box also appears above the list
indicating the following: "The list of 200 systems below is filtered - only
systems with the term 'wkstation' are displayed below. _Clear this filter and
view all 1,000 systems_"  (feasibility?)

(3) I click to move to page 2 of the list and the list-info box still appears.

(3) The page count (e.g., "1 - 1 of 1") for the list would instead say "1-10 of
200 (1,000 total) (2 selected)" (yes this is kind of confusing but better than
nothing)

(4) I clear the filter (using a clear button?) and the list-info box disappears.
I now see all 1,000 systems. The page count returns to "1-10 of 1,000"

Comment 1 Máirín Duffy 2007-05-10 15:10:22 UTC
Created attachment 154476 [details]
screenshot of a filtered list in the current webui, with pointers to problems

Comment 2 Máirín Duffy 2007-05-10 16:10:59 UTC
Created attachment 154482 [details]
suggested improvements

Comment 3 Jan Pazdziora 2007-07-13 09:14:38 UTC
Setting the sat‑5.1.0 ? flag since the bug was under rhn500s-should.

Comment 4 Justin Sherrill 2007-10-11 18:22:47 UTC
fixed for the new list tag in rev 132837.

If we want it on any other pages we should just migrate that page to the new
list tag.

Comment 5 Partha Aji 2007-10-19 18:11:58 UTC
Moving to ON_QA

Comment 6 wes hayutin 2007-10-23 13:01:14 UTC
this looks great.. nice job!
verified build 20

Comment 8 Brandon Perkins 2008-04-02 21:08:11 UTC
UI Enhancements for 5.1 Sat GA so Closed for Current Release.


Note You need to log in before you can comment on or make changes to this bug.