Bug 239713 - No PPC64 build of ghc
No PPC64 build of ghc
Product: Fedora
Classification: Fedora
Component: ghc (Show other bugs)
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
: Reopened
: 239751 (view as bug list)
Depends On:
Blocks: FE-ExcludeArch-ppc64 239752 246051
  Show dependency treegraph
Reported: 2007-05-10 13:50 EDT by Bryan O'Sullivan
Modified: 2014-11-09 17:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-06-06 02:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2007-05-10 13:50:39 EDT
Not ported to ppc64 yet.
Comment 1 David Woodhouse 2007-05-10 13:56:21 EDT
mail me a ssh public key; you can have an account on a suitable box :)
Comment 2 Jens Petersen 2007-05-10 19:54:33 EDT
*** Bug 239751 has been marked as a duplicate of this bug. ***
Comment 3 Jens Petersen 2007-05-10 19:56:03 EDT
As I commented in the above bug:

I think older versions of ghc have been built for ppc64
on debian and gentoo.  Might need to do a multistage bootstrap...

Comment 4 Jeremy Hinegardner 2007-07-25 15:40:19 EDT
Not sure if this bug should get some attention soon, I was just notified that we
now have broken build dependencies in development. python-vcpx (used by tailor)
depends on darcs.
Comment 5 Jens Petersen 2007-07-25 22:17:30 EDT
Yup it would be good to have - unfortunately it is quite a lot of work.

I found ghc-6.4.2 for ppc64 in gentoo and just sent mail to glasgow-haskell list
and the PPC SIG people for input and help.
Comment 7 Dan Horák 2007-08-17 15:35:17 EDT
(In reply to comment #4)
> Not sure if this bug should get some attention soon, I was just notified that we
> now have broken build dependencies in development. python-vcpx (used by tailor)
> depends on darcs.

python-vcpx has runtime dependency on darcs
Comment 8 Jens Petersen 2007-08-19 20:41:52 EDT
Yes, we're well aware of the problem.
Unfortunately bootstrapping ghc on ppc64 is non-trivial. :-/
I have started some work on it but it is currently stalled
(I hope to return to it soon again).

Comment 9 Jens Petersen 2008-01-10 02:47:16 EST
Forgot to update on my last attempt a while back, but unfortunately
it was not successful.  I ran into some missing symbol problems
when I tried to bootstrap from a binary from gentoo IIRC.
Comment 10 David Woodhouse 2008-04-18 08:37:25 EDT
http://hackage.haskell.org/trac/ghc/ticket/1346 discusses bootstrap issues with

We might find it easier to bootstrap on ppc64 than in the general case, because
we can run ppc32 binaries.
Comment 11 David Woodhouse 2008-04-18 12:21:59 EDT
I followed the cross-compile instructions at
http://hackage.haskell.org/trac/ghc/wiki/Building/Porting to build ghc-6.61 in a
Fedora 7 mock root.

It doesn't seem to work correctly, though. The newly-built 'ghc-inplace'
compiler just gets stuck, with a zombie 'gcc' child, in select():

mock-chroot> ../compiler/ghc-inplace  -v -optc-O -optc-Wall -optc-W
-optc-Wstrict-prototypes -optc-Wmissing-prototypes -optc-Wmissing-declarations
-optc-Winline -optc-Waggregate-return -optc-Wbad-function-cast
-optc-I../includes -optc-I. -optc-Iparallel -optc-DCOMPILING_RTS
-optc-fomit-frame-pointer -optc-DNOSMP -optc-fno-strict-aliasing -H16m -O
-optc-O2 -optc-DNOSMP -static -I. -#include HCIncludes.h -fvia-C -dcmm-lint    
-c Adjustor.c -o Adjustor.o
Glasgow Haskell Compiler, Version 6.6.1, for Haskell 98, compiled by GHC version
Using package config file:
wired-in package base not found.
wired-in package rts mapped to rts-1.0
wired-in package haskell98 not found.
wired-in package template-haskell not found.
Hsc static flags: -funregisterised -static -static
Created temporary directory: /tmp/ghc27293_0
*** C Compiler:
gcc -x c Adjustor.c -o /tmp/ghc27293_0/ghc27293_0.s -v -S -Wimplicit -O
-Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Winline
-Waggregate-return -Wbad-function-cast -I../includes -I. -Iparallel
-DCOMPILING_RTS -fomit-frame-pointer -DNOSMP -fno-strict-aliasing -O2 -DNOSMP -I
. -I /builddir/build/BUILD/ghc-6.6.1/includes -fwrapv
Comment 12 Bug Zapper 2008-05-13 22:53:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 13 Bryan O'Sullivan 2008-05-28 16:33:05 EDT
Unfortunately, I don't have cycles to do anything about this.  Lowering priority.
Comment 14 Jens Petersen 2008-11-09 21:10:15 EST
Seems gentoo are still working on ppc64: http://bugs.gentoo.org/206643
Comment 15 Bug Zapper 2008-11-25 20:54:00 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 16 Bug Zapper 2009-11-18 07:19:08 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 17 Jens Petersen 2009-11-19 22:50:44 EST
Given that ppc is now a secondary arch as of F13 I propose to close this.
Of course if someone pushing the ppc arch wants to pick it up
we are happy to work with them but it is no longer a priority for
the Haskell SIG.
Comment 18 Jens Petersen 2011-05-25 05:01:16 EDT
Jiri Skala has been working on this recently.

Comment 19 Jens Petersen 2011-06-01 22:52:44 EDT
ghc-7.0.2-16.2.fc15 is built for dist-f15:

The ppc64 port has some restrictions though: no ghci so no TH
(template haskell) and no threaded rts.
Currently 5 library packages in fedora require TH.

Note You need to log in before you can comment on or make changes to this bug.