Bug 239923 - Bootup message regarding selinux files
Bootup message regarding selinux files
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
: 239944 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-05-12 10:09 EDT by Bob Blum
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-12 13:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Blum 2007-05-12 10:09:17 EDT
Description of problem:

Early in the boot-up process, a message flashes across the screen saying
"/etc/selinux/targeted/contexts/files/file_contexts: Multiple different
specifications for /usr/lib/vlc/codec/libdmo_plugin.so" and, in addition cites
several other files with the same introductory statement.  

This first appeared after a recent update of Fedora Core 6.  To test it, I
reloaded a backup of Fedora Core 6 from early March and the message does not
appear.  Then I performed a standard update and the message appeared.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Ahmed Kamal 2007-05-14 09:56:04 EDT
Confirmed, I see that message whenever I run "yum -y upgrade"
Comment 2 Daniel Walsh 2007-05-14 13:29:43 EDT
  Fixed in selinux-policy-2.4.6-69.fc6
Comment 3 Daniel Walsh 2007-05-14 13:30:35 EDT
*** Bug 239944 has been marked as a duplicate of this bug. ***
Comment 4 Andy Day 2007-05-27 05:49:25 EDT
Still seeing this error on bootup after updating with latest selinux-policy and vlc.
Comment 5 Bob Blum 2007-05-27 09:39:36 EDT
Agree with Andy Day.  Fix did not work.  Still seeing the error on bootup, even
after updating selinix-policy.
Comment 6 Daniel Walsh 2007-05-29 11:11:34 EDT
Are you seeing multiple duplicate now?  If yes you need to remove the one
installed by the vlc installer.

semanage fcontext -d /usr/lib/vlc/codec/libdmo_plugin.so
Comment 7 Bob Blum 2007-05-29 19:48:10 EDT
After reading the message from Daniel Walsh, I ran the following two commands in
a terminal:

semanage fcontext -d /usr/lib/vlc/codec/libdmo_plugin.so
semanage fcontext -d /usr/lib/vlc/codec/librealaudio_plugin.so

These removed the bootup messages.  However, there is still a perceptible pause
in the boot process at the point where the messages previously appeared.
Comment 8 Daniel Walsh 2007-09-12 13:08:07 EDT
Moving modified bugs to closed

Note You need to log in before you can comment on or make changes to this bug.