Bug 239928 - Eject LiveCD on shutdown
Eject LiveCD on shutdown
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
: FutureFeature
: 446709 (view as bug list)
Depends On: 448997
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2007-05-12 13:26 EDT by Guy Van Den Bergh
Modified: 2013-01-09 23:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-19 12:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Guy Van Den Bergh 2007-05-12 13:26:55 EDT
Description of problem:
Fedora 7 test4 works fine, but when I shut the system down (from the menu),
the LiveCD is not ejected. It would be a lot more practical if it would, like
KNOPPIX does.


How reproducible:
Not tried to reproduce, later if I have time.

Steps to Reproduce:
1. Boot Fedora 7 test4 i386 Live CD on laptop
2. Select Shutdown from the System menu
3. Wait until the system powers off
  
Actual results:
The LiveCD is locked inside the closed cd/dvd tray.

Expected results:
The LiveCD is ejected before power off.
Comment 1 Jeremy Katz 2007-05-14 12:11:16 EDT
We'd like to do an eject eventually, but that's going to require some changes in
the underlying infrastructure so that we can pass control back to the initramfs
to do the eject.  Not going to happen for F7
Comment 2 Jesse Keating 2008-03-31 13:49:51 EDT
Jeremy, did this happen for F9?  Should we punt again?
Comment 3 Bug Zapper 2008-05-13 22:53:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jeremy Katz 2008-05-15 17:33:42 EDT
*** Bug 446709 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2008-05-29 14:41:46 EDT
Okay, this is going to be tied in with some of the changes we have pending for
Fedora 10 around upstart.  We need to have a way to drop in things to run
"late-ish" during the shutdown process but prior to running /sbin/halt so that
we can eject when there's only a bare minimum set of things left to do.

Or perhaps even adding the support to halt/reboot itself to do this eject if
given the appropriate argument

In any case, definitely needs to be handled for F10.
Comment 6 Valent Turkovic 2008-06-04 02:56:36 EDT
Great! This feature is really helpful because if you need to take the CD out
then you need to poweroff, eject and poweoff (usually in mid boot) the PC again :(
Comment 7 Jeremy Katz 2008-06-05 21:52:56 EDT
Did the hack in /sbin/halt.local for now.  It's not as reliable as if we get the
support into /sbin/halt directly per the bug that's blocking this, but it'll do
for the moment.
Comment 8 John R. Deal Jr. 2008-08-23 11:46:56 EDT
First time commenting so please let me know if this is not useful.

Live CD ejected when issuing shutdown from GNOME menu but produced error messages and did not shutdown system.

 
System: IBM NetVista desktop (real desktop, not tower) vintage 2000/2001, Intel P4 1.8 GHz, 1.25 GB RAM

Using F10 Live CD build (from uname -a):
2.6.27-0.166.rc0.git8.fc10.i686 #1 smp mon jul 21 20:51:26 EDT 2008 i686 i686 i386 gnu/linux

Steps to reproduce:

1.  Boot off Live CD
2.  Select Shutdown from GNOME menu
3.  Comfirm Shutdown on dialog box
4.  Observe Device Not Ready on sr0 I/O Error dev sr0 sector 1386872 messages
    (sector alternates with 1386876)
5.  Remove CD from tray
6.  Close CD tray
7.  Wait.  System stays in this state
8.  Press <enter>.  No result
9.  Press ramdom keys.  Keys echo on display but no further action.
10. Power reset.  System boots normally.
Comment 9 John R. Deal Jr. 2008-08-23 16:15:19 EDT
I feel the above maybe a result of a CD drive failure.  As soon as I can replace the CD drive I will retry.  Sorry for wasting your time.
Comment 10 Charles R. Anderson 2008-10-19 12:34:12 EDT
Works for me on F10 Snap2.

Note You need to log in before you can comment on or make changes to this bug.