Bug 239990 - Boot screens have corrupted graphics
Summary: Boot screens have corrupted graphics
Status: CLOSED DUPLICATE of bug 238831
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-14 07:13 UTC by Justin Mahoney
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 02:35:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of openSUSE 10.3 Alpha 3 booting in guest VM. (150.66 KB, image/png)
2007-05-14 07:13 UTC, Justin Mahoney
no flags Details

Description Justin Mahoney 2007-05-14 07:13:34 UTC
Description of problem:

When booting virtual machines, the screen graphics often (nearly always) are
corrupt. See attachment.

Version-Release number of selected component (if applicable):

virt-manager 0.4.0, Fedora 7 Test 4

How reproducible:

I'm using openSUSE 10.3 Alpha 3 (both booting the installer and the installed OS
in a VM). The problem was also manifested itself with Windows 2000 Professional
installer (there were also minor graphics errors throughout the w2k installer
process on the blue install screens).

Steps to Reproduce:
1. Create a new VM under virt-manager using Full Virtualization with hardware
acceleration. I have a dual Opteron 2214 setup. I'm using an e-GeForce 7600GT
PCI-X 16x video card. I have not installed any video drivers beyond what came
with Fedora 7 Test 4.
2. Boot off of a Windows 2000 Professional or openSUSE 10.3 Alpha 3 disk. The
initial screens and some subsequent screens have graphics corruption. Usually
the first screen or two is major, leading to an unreadable screen (see
attachment of installed guest OS booting), subsequent screens (such as w2k
installer blue screens) are minor.

Comment 1 Justin Mahoney 2007-05-14 07:13:34 UTC
Created attachment 154621 [details]
Screenshot of openSUSE 10.3 Alpha 3 booting in guest VM.

Comment 2 Justin Mahoney 2007-05-14 07:15:14 UTC
Sorry, it's a PCI-Express card, not PCI-X as I stated above.

Comment 3 Justin Mahoney 2007-05-14 07:16:22 UTC
In the screenshot it appears I am booting Fedora 7. I want to make it clear I
was booting openSUSE 10.3 Alpha 3. It appears part of the corruption involves
errantly copying from the video memory of the host OS.

Comment 4 Daniel Berrange 2007-05-14 13:21:49 UTC
What happens if you close the console window & re-open it immediately? Does the
corrupt graphics rectify itself. At first guess I'd say this was a dup of bug
238831 in which the VNC server does not send correct refreshes after a
resolution change. If this is correct, closing & reopening the console window
would clear the corruption.

Comment 5 Red Hat Bugzilla 2007-07-25 02:11:45 UTC
change QA contact

Comment 6 Daniel Berrange 2007-10-05 02:35:20 UTC

*** This bug has been marked as a duplicate of 238831 ***


Note You need to log in before you can comment on or make changes to this bug.