Bug 240081 - ICH7 No Sound after 2944 Kernel
ICH7 No Sound after 2944 Kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 19:21 EDT by Andy Lawrence
Modified: 2008-01-08 19:56 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 19:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log (47.67 KB, text/plain)
2007-05-14 19:21 EDT, Andy Lawrence
no flags Details

  None (edit)
Description Andy Lawrence 2007-05-14 19:21:13 EDT
Description of problem:
No sound from:
Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
sometime after the 2944 Kernel.  Boot to 2944 Kernel sound works fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always
Steps to Reproduce:
1.  Boot to latest 3116 kernel no sound
2.  Reboot to 2944 sound works great
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andy Lawrence 2007-05-14 19:21:13 EDT
Created attachment 154696 [details]
scsconfig.log
Comment 2 Antonio A. Olivares 2007-05-23 15:32:16 EDT
I have a toshiba satellite A135-S4527 computer and sound does not work period. 
I installed F7 - Test 4 from LiveCD Gnome 6.93 and I got no sound.  I can get
sound from slax rc 2 but not from slax rc 3.  In slax rc 2 the sound utility
kmix reported realtek ??? and used OSS drivers.  

Here's lspci from this computer.

[root@localhost ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
04:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g
Wireless PCI Express Adapter (rev 01)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI
Express Fast Ethernet controller (rev 01)
06:04.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
06:04.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394
Host Controller
06:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader
(SD/MMC/MS/MS PRO/xD)
06:04.3 Generic system peripheral [0805]: Texas Instruments PCIxx12 SDA Standard
Compliant SD Host Controller
[root@localhost ~]#  

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.21-1.3189.fc7 #1 SMP Tue May 22 17:14:22 EDT
2007 i686 i686 i386 GNU/Linux
[root@localhost ~]# cat /etc/fedora-release
Fedora release 6.93 (Rawhide)
[root@localhost ~]# 

If you need further information please contact me.  
Comment 3 Chuck Ebbert 2007-05-23 16:45:13 EDT
I sent davej two patches that should fix this.
Comment 4 sean 2007-05-27 14:57:36 EDT
I have:
Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio
Controller (rev 02)

Is this the same bug, or should I open a new one?
Comment 5 sean 2007-05-28 09:07:44 EDT
Tried 3207 on emt64 - hda-intel. Works For Me.

I'll check the amd64 later.
Comment 6 Andy Lawrence 2007-05-28 10:08:24 EDT
No go for me with the 3207 i686.
Comment 7 Antonio A. Olivares 2007-05-28 11:58:35 EDT
Does not work for me either.  Tried with 3201.  
Comment 8 Andy Lawrence 2007-06-02 17:51:23 EDT
All, Sound is now working with the following edit of /etc/modprobe.conf

options snd-hda-intel index=0

to read:

options snd-hda-intel index=0 model=3stack
Comment 9 Josep 2007-06-16 05:32:10 EDT
I can confirm the bug in a Dell XPS-M1210.
Sound worked when first boot run after installing Fedora 7. I think it was using
kernel version kernel-2.6.21-1.3194.fc7 (i686), with the current kernel
(kernel-2.6.21-1.3228.fc7) it fails.

The solution proposed in comment #8 doesn't work here, it could be the
difference in the chipset version (I have rev 01, Andy has rev 02):
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)

I also get these error messages in dmesg:
hda-intel: Error creating card!
HDA Intel: probe of 0000:00:1b.0 failed with error -12

Comment 10 Josep 2007-06-16 06:03:03 EDT
bug #242244 could be a duplicate of this one.
Comment 11 Erik Sjölund 2007-08-06 14:03:06 EDT
The solution in comment #8 worked for me ( after a reboot ).

# rpm -q kernel
kernel-2.6.22.1-41.fc7

# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)

My computer is of the model Dell Dimension 5100
Comment 12 Josep 2007-08-22 15:53:07 EDT
The problem I reported in comment #9 is solved with the current kernel (without
having to apply the solution in comment #8).

# uname -r
2.6.22.1-41.fc7

# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)

Note You need to log in before you can comment on or make changes to this bug.