Bug 242244 - Fedora usually doesn't find my builtin Intel ICH7 soundcard
Summary: Fedora usually doesn't find my builtin Intel ICH7 soundcard
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 16:43 UTC by Espen Stefansen
Modified: 2008-01-13 16:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 18:34:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log of a non-working boot (44.97 KB, text/plain)
2007-06-02 16:43 UTC, Espen Stefansen
no flags Details
scsconfig log (48.05 KB, text/plain)
2007-10-31 18:32 UTC, Warren Smith
no flags Details

Description Espen Stefansen 2007-06-02 16:43:29 UTC
Description of problem:
Fedora can't find my builtin Intel ICH7 soundcard. I also have an USB-soundcard 
which it always finds. After a few reboots, it usually find the Intel 
soundcard. This problem also happened on FC6.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3194.fc7

How reproducible:
Almost everytime, but can go away after a few reboots.

Steps to Reproduce:
1. Boot
2. After logging in, it only finds my USB soundcard
3.
  
Actual results:
After logging in, it only finds my USB soundcard

Expected results:
Should find both soundcards, _every_ time.

Additional info:
Between a working and non-working boot, heres the difference in scsconfig.log:
1430,1432d1307
< AC'97 0 analog subsections not ready
< intel8x0_measure_ac97_clock: measured 50129 usecs
< intel8x0: clocking to 48000
1433a1309,1310
> cannot find the slot for index 0 (range 0-0), error: -16
> Intel ICH: probe of 0000:00:1e.2 failed with error -12

lspci -v:

00:1e.2 Multimedia audio controller: Intel Corporation 82801G (ICH7 Family) 
AC'97 Audio Controller (rev 01)
        Subsystem: Dell Unknown device 01ad
        Flags: bus master, medium devsel, latency 0, IRQ 21
        I/O ports at ec00 [size=256]
        I/O ports at e8c0 [size=64]
        Memory at febffa00 (32-bit, non-prefetchable) [size=512]
        Memory at febff900 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

Comment 1 Espen Stefansen 2007-06-02 16:43:29 UTC
Created attachment 155986 [details]
scsconfig.log of a non-working boot

Comment 2 Josep 2007-06-16 09:50:04 UTC
Maybe this is a duplicate of bug #240081, I reported there too.

This is my "lspci -v":

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
        Subsystem: Dell Unknown device 01d7
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at efebc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-
        Capabilities: [70] Express Unknown type IRQ 0


Comment 3 Chuck Ebbert 2007-08-22 20:40:54 UTC
(In reply to comment #1)
> Created an attachment (id=155986) [edit]
> scsconfig.log of a non-working boot
> 

Please post contents of /etc/modprobe.conf

Comment 4 Espen Stefansen 2007-08-22 21:48:07 UTC
[root@test ~]# cat /etc/modprobe.conf
alias eth0 tg3
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/
modprobe -r --ignore-remove snd-intel8x0
install pcspkr :


Comment 5 Espen Stefansen 2007-08-22 21:49:35 UTC
Oh... this still happens on kernel-2.6.22.2-57.fc7.

Comment 6 Espen Stefansen 2007-09-08 14:04:53 UTC
I should mention that when the usb-soundcard is not connected to my computer, it
always finds my built-in soundcard. So this might be some usb-problems.

Comment 7 Chuck Ebbert 2007-09-10 23:03:45 UTC
Problem is usually in the order in which the sound adapters are discovered. If
usb is discovered first it will try to use the wrong drivers.


Comment 8 Warren Smith 2007-10-31 18:32:10 UTC
Created attachment 244821 [details]
scsconfig  log

Comment 9 Christopher Brown 2008-01-09 00:57:15 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Comment 10 Espen Stefansen 2008-01-11 14:46:54 UTC
The computer has been upgraded to F8, but the problem still occurs using kernel-2.6.23.9-85.fc8.

From /var/log/messages:
kernel: usbcore: registered new interface driver snd-usb-audio
kernel: cannot find the slot for index 0 (range 0-0), error: -16
kernel: Intel ICH: probe of 0000:00:1e.2 failed with error -12

lspci -vvv:
00:1e.2 Multimedia audio controller: Intel Corporation 82801G (ICH7 Family) AC'97 Audio Controller 
(rev 01)
        Subsystem: Dell Unknown device 01ad
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- 
SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- 
<MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 3
        Region 0: I/O ports at ec00 [size=256]
        Region 1: I/O ports at e8c0 [size=64]
        Region 2: Memory at febffa00 (32-bit, non-prefetchable) [size=512]
        Region 3: Memory at febff900 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Kernel modules: snd-intel8x0

[root@platon ~]# cat /etc/modprobe.conf
alias eth0 tg3
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-
remove snd-intel8x0
install pcspkr :



Comment 11 Chuck Ebbert 2008-01-11 15:51:00 UTC
You need to add snd-card-1 to modprobe.conf for the snd-usb-audio adapter.

Like:

alias snd-card-1 snd-usb-audio
options snd-card-1 index=1
options snd-usb-audio index=1


Comment 12 Espen Stefansen 2008-01-11 18:04:11 UTC
That worked. :) 

But shouldn't this work automatically? The USB-soundcard is a Logitech wireless soundcard connected 
to my stereo, so there could be more people experiencing this. We can't expect everyone to configure 
modprobe.conf by hand?

Comment 13 Christopher Brown 2008-01-11 18:34:10 UTC
Hi Espen,

I'll keep an eye out for similar reports - it may be that hardware detection was
broken in F7 and the upgrade to F8 didn't over-write the old settings.

Closing ERRATA - thanks for filing!


Note You need to log in before you can comment on or make changes to this bug.