Bug 240129 - system-config-users fails when explicit group is specified for new user
Summary: system-config-users fails when explicit group is specified for new user
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-users   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
: 242224 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-15 13:01 UTC by Richard Ryniker
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 1.2.58
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 04:16:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Ryniker 2007-05-15 13:01:36 UTC
Description of problem:
Cannot use explicit gid when creating new user with GUI tool.
Command-line tool "adduser" works without difficulty.

Version-Release number of selected component (if applicable):
Version     : 1.2.56
Release     : 1.fc7

How reproducible:
Always.


Steps to Reproduce:
1. Invoke system-config-users as root.
2. Create new group with explicit gid.
3. Try to create new user with explicit gid (just created) and explicit uid.
  
Actual results:
[root@vista ryniker]# system-config-users
Traceback (most recent call last):
  File "/usr/share/system-config-users/userWindow.py", line 289, in
on_userWin_ok_button_clicked
    if self.gidCheckButton.get_active ():
AttributeError: userWindow instance has no attribute 'gidCheckButton'
[root@vista ryniker]#

Expected results:


Additional info:

Comment 1 Nils Philippsen 2007-05-24 13:49:53 UTC
fixing version/component

Comment 2 Nils Philippsen 2007-05-24 14:10:24 UTC
system-config-users-1.2.58 is building right now which should fix this problem.

Comment 3 Fedora Update System 2007-06-04 04:16:22 UTC
system-config-users-1.2.58-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Nils Philippsen 2007-06-04 07:20:17 UTC
*** Bug 242224 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.