Bug 242224 - New user dialog hangs due to exception
New user dialog hangs due to exception
Status: CLOSED DUPLICATE of bug 240129
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 06:57 EDT by Tony Tsui
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 03:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Tsui 2007-06-02 06:57:41 EDT
Description of problem:
The new user dialog hangs due to an exception when creating a new user with
"Specify group ID manually" selected.

Version-Release number of selected component (if applicable):
system-config-users-1.2.56-1.fc7

How reproducible:
Everytime

Steps to Reproduce:
1.Click Add User button
2.Enter details for user.
3.Check "Specify group ID manually"
4.Click OK button.
  
Actual results:
The dialog just hangs. The follow python exception is outputted.

[root@rifter ~]# system-config-users 
Traceback (most recent call last):
  File "/usr/share/system-config-users/userWindow.py", line 289, in
on_userWin_ok_button_clicked
    if self.gidCheckButton.get_active ():
AttributeError: userWindow instance has no attribute 'gidCheckButton'

Expected results:
The new user is created.
Comment 1 Tom Horsley 2007-06-02 09:11:25 EDT
Yep, just tried this on my fresh install of f7 with same results, doing a
useradd from  a terminal worked fine (should have done that first anyway :-).

I wanted to specify group ID and existing home directory to create the same
user I had on fc6 pointing to same home dir on 2nd disk drive.
Comment 2 Nils Philippsen 2007-06-04 03:20:14 EDT

*** This bug has been marked as a duplicate of 240129 ***

Note You need to log in before you can comment on or make changes to this bug.