Bug 240253 - Removing openldap-devel breaks sudo command
Removing openldap-devel breaks sudo command
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
: 249866 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-15 22:21 EDT by Kevin Cozens
Modified: 2009-07-29 10:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 07:55:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Cozens 2007-05-15 22:21:34 EDT
My latest run of 'yum update' included an update for openldap-devel. Since I
don't plan to do any development related to ldap I removed the package 'using
rpm -e openldap-devel'. I then discovered I could no longer use the 'sudo'
command. The sudo command would give me the message:

sudo: error while loading shared libraries: libldap-2.3.so.0: cannot open shared
object file: No such file or directory

When I re-install the openldap-devel package I am able to use the sudo command
once more.

The above happens consistently. When I remove openldap-devel I no longer have
the /usr/lib/libldap.so file and can't run sudo. When I install openldap-devel I
can use the sudo command.
Comment 1 Jan Safranek 2007-05-16 04:13:18 EDT
Thank you for the bug report. There is just missing 'ldconfig' in %postun of
openldap-devel.

You can safely remove openldap-devel, but afterwards you must manually call
ldconfig as root:
rpm -e openldap-devel
ldconfig

I'll fix it in next release of openldap rpms.
Comment 2 Jan Safranek 2007-06-08 07:55:54 EDT
Fixed in openldap-2.3.34-3.fc8
Comment 3 Jan Safranek 2007-10-18 11:21:16 EDT
*** Bug 249866 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.