Bug 249866 - Removing openldap-devel RPM breaks openldap libraries
Removing openldap-devel RPM breaks openldap libraries
Status: CLOSED DUPLICATE of bug 240253
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 11:22 EDT by David Shaw
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 11:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shaw 2007-07-27 11:22:23 EDT
Description of problem:

If you have both openldap and openldap-devel installed, and then remove
openldap-devel, it breaks one of the libraries installed by openldap.

Version-Release number of selected component (if applicable):

openldap-2.3.30-2.fc6
openldap-devel-2.3.30-2.fc6

Steps to Reproduce:
1. Install openldap & openldap-devel RPMs
2. rpm -e openldap-devel
3. Try to run a program (for example "svn") that uses openldap.

Actual results:

svn: error while loading shared libraries: libldap-2.3.so.0: cannot open shared
object file: No such file or directory

Workaround:

  cd /usr/lib
  # ln -s libldap-2.3.so.0.2.18 libldap.so
  # ln -s liblber-2.3.so.0
  # ln -s libldap_r-2.3.so.0.2.18 libldap_r-2.3.so
Comment 1 Jan Safranek 2007-10-18 11:21:15 EDT
I am sorry for long time to reply, I somehow missed the bug. It was already
reported and fixed in rawhide and F7.

*** This bug has been marked as a duplicate of 240253 ***

Note You need to log in before you can comment on or make changes to this bug.