Bug 240257 - gnome-about-me sets wrong permissions on user face icon
gnome-about-me sets wrong permissions on user face icon
Status: CLOSED DUPLICATE of bug 236393
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2007-05-15 23:23 EDT by Eric Harney
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-16 04:43:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Harney 2007-05-15 23:23:33 EDT
Description of problem:
gnome-about-me creates ~/.face for a user when they select an icon in it.  It is
created with permissions -rw-rw-r-- .
gdm does not like the group write permission being on, and refuses to display
the icon.

May 15 23:15:03 localhost gdm[4754]: run_pictures: /home/wkc/.face is writable
by group.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Create a new user
2. Log into gnome and run gnome-about-me
3. Click on the icon in the upper-left and select a logo
4. Log out to gdm
Actual results:
gdm does not display logo for this user

Additional info:
It does display a logo for my primary user account, but not this new one which
was recently created.  Not sure what the difference is.
Comment 1 Matthias Clasen 2007-05-16 00:55:48 EDT
Confirmed. Bastian, we need to get -16 tagged for f7-final.
Comment 2 Bastien Nocera 2007-05-16 04:43:39 EDT
Sigh. Ray was supposed to tag it when he took care of bug 235484...

Mail sent, closing this bug as the dupe that it is.

*** This bug has been marked as a duplicate of 236393 ***

Note You need to log in before you can comment on or make changes to this bug.