Bug 240298 - ls -x broken
Summary: ls -x broken
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 242197 (view as bug list)
Depends On:
Blocks: F7Update
TreeView+ depends on / blocked
 
Reported: 2007-05-16 12:33 UTC by Gary Benson
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 6.9-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 03:53:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Better fix? (1.07 KB, patch)
2007-05-16 12:57 UTC, Gary Benson
no flags Details | Diff

Description Gary Benson 2007-05-16 12:33:02 UTC
Description of problem:
If you do ls -x, the first item in the list will be replaced by a random other
entry.

Version-Release number of selected component (if applicable):
coreutils-6.9-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. Open a terminal
2. Enter 'ls -x'
3. Observe that the first item in the list is wrong
  
Actual results:
flowers:[~]$ /bin/ls -x
spoof  Desktop   lj    mark.ppm  music  note  old  personal  photos  projects
spoof  sysadmin  temp  toybox    work

Expected results:
flowers:[~]$ /bin/ls
bin      lj        music  old       photos    spoof     temp    work
Desktop  mark.ppm  note   personal  projects  sysadmin  toybox

Comment 1 Jim Meyering 2007-05-16 12:41:00 UTC
Thanks for the report.
This was fixed upstream, but is not in a stable release:

NEWS:
  ls -x DIR would sometimes output the wrong string in place of the
  first entry.  [introduced in coreutils-6.8]

Here's the upstream fix:

  http://git.sv.gnu.org/gitweb/?p=coreutils.git;a=commitdiff;h=a3b65a63a0e

Comment 2 Gary Benson 2007-05-16 12:57:47 UTC
Created attachment 154815 [details]
Better fix?

Yeah, that's the one.  Does the upstream fix work when there is nothing to
list? It looks like sorted_file[0] would be some random pointer in that case.
FWIW this is the fix I came up with (based on what's in F7, not upstream).

Comment 3 Jim Meyering 2007-05-16 13:26:27 UTC
Hi Gary,
Good point: that patch is a little fragile.  However, it does appear to work
even  in that case, since when there are no entries to list, cwd_n_used is 0, in
which case print_horizontal cannot be called.  But if you find a way to make ls
misbehave, please let me know.

Comment 4 Gary Benson 2007-05-16 13:49:10 UTC
Ah, that would explain it.

Comment 5 Tim Waugh 2007-06-04 17:08:11 UTC
*** Bug 242197 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2007-06-13 21:03:29 UTC
coreutils-6.9-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-06-27 03:53:05 UTC
coreutils-6.9-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.