Bug 242197 - ls -x produces a garbled listing
ls -x produces a garbled listing
Status: CLOSED DUPLICATE of bug 240298
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 01:21 EDT by Stephen Moehle
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 13:08:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Moehle 2007-06-02 01:21:05 EDT
"ls -x" or "ls --format=across" produces a garbled listing.

To reproduce, create a directory with the files a_file, b_file, ... i_file.

ls produces:

a_file  b_file  c_file  d_file  e_file  f_file  g_file  h_file  i_file

ls -x produces:

e_file  b_file  c_file  d_file  e_file  f_file  g_file  h_file  i_file

Notice that a_file is missing and e_file appears twice. This problem was not in
FC6 and is brand new with F7.
Comment 1 Marek Mahut 2007-06-03 05:24:46 EDT
bug in coreutils, reassigning
Comment 2 Marek Mahut 2007-06-03 05:26:41 EDT
bug is know to upstream, it was already fixed in CVS [1] 2 months ago


[1]
http://cvs.savannah.gnu.org/viewvc/coreutils/src/ls.c?revision=1.457&root=coreutils&view=markup
Comment 3 Tim Waugh 2007-06-04 13:08:09 EDT

*** This bug has been marked as a duplicate of 240298 ***

Note You need to log in before you can comment on or make changes to this bug.