Bug 240352 - nfs-utils postuninstall scriptlet failure on upgrade
nfs-utils postuninstall scriptlet failure on upgrade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On: 240225
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 13:39 EDT by Steve Dickson
Modified: 2011-09-26 01:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0651
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2007-05-16 13:39:20 EDT
+++ This bug was initially created as a clone of Bug #240225 +++

Upgrading from nfs-utils-1.0.10-7.fc6.x86_64 to nfs-utils-1.0.10-10.fc6.x86_64
when nfs is not running results in:

error: %postun(nfs-utils-1.0.10-7.fc6.x86_64) scriptlet failed, exit status 1

...and subsequently:

$ rpm -q nfs-utils
nfs-utils-1.0.10-7.fc6.x86_64
nfs-utils-1.0.10-10.fc6.x86_64

This is because /etc/init.d/nfs condrestart returns an error code (1) if nfs is
not running:

# /etc/init.d/nfs status
rpc.mountd is stopped
nfsd is stopped
# /etc/init.d/nfs condrestart
# echo $?
1

Fix: make nfs condrestart exit with 0 if nfs is not running.

-- Additional comment from bugs.michael@gmx.net on 2007-05-16 06:47 EST --
*** Bug 240268 has been marked as a duplicate of this bug. ***

-- Additional comment from steved@redhat.com on 2007-05-16 13:14 EST --
Fixed in nfs-utils-1.0.10-11
Comment 1 RHEL Product and Program Management 2007-05-16 13:43:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Steve Dickson 2007-05-17 14:20:27 EDT
Fixed in nfs-utils-1.0.9-18.el5
Comment 6 Steve Dickson 2007-08-30 07:38:46 EDT
Yeah... ;-)
Comment 9 errata-xmlrpc 2007-11-07 12:15:29 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0651.html

Note You need to log in before you can comment on or make changes to this bug.