Bug 240525 - [liberation-fonts] Alignment mismatch of dot accents.
Summary: [liberation-fonts] Alignment mismatch of dot accents.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: liberation-fonts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 304441
TreeView+ depends on / blocked
 
Reported: 2007-05-18 08:39 UTC by Trevor Spiteri
Modified: 2008-04-01 03:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 03:23:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Liberation Sans dot accents not aligned with i dot (24.16 KB, image/png)
2007-05-18 08:39 UTC, Trevor Spiteri
no flags Details
Liberation Serif dot accents not aligned with i dot (24.35 KB, image/png)
2007-05-18 08:40 UTC, Trevor Spiteri
no flags Details
Liberation Mono dot accents not aligned with i dot (23.85 KB, image/png)
2007-05-18 08:41 UTC, Trevor Spiteri
no flags Details
proof 1/3 (39.35 KB, image/png)
2008-01-23 05:59 UTC, Caius Chance
no flags Details
proof 2/3 (44.55 KB, image/png)
2008-01-23 05:59 UTC, Caius Chance
no flags Details
proof 3/3 (40.37 KB, image/png)
2008-01-23 05:59 UTC, Caius Chance
no flags Details
Test result pictures - serif. (27.67 KB, image/png)
2008-03-25 03:21 UTC, Caius Chance
no flags Details
Test result pictures - sans. (27.01 KB, image/png)
2008-03-25 03:21 UTC, Caius Chance
no flags Details
Test result pictures - mono. (24.89 KB, image/png)
2008-03-25 03:21 UTC, Caius Chance
no flags Details
Revised fonts. (1.10 MB, application/x-gzip)
2008-03-25 03:22 UTC, Caius Chance
no flags Details

Description Trevor Spiteri 2007-05-18 08:39:24 UTC
For the Liberation fonts, in characters with dot accents, the dots are not
aligned with the dot on the letter i. For some faces, the misalignment is more
pronounced, particularly in the Liberation Sans regular font.

The problem is shown in the screenshots for dotted c (Unicode 10B), dotted e
(117), dotted g (121), and dotted z (17c).

Comment 1 Trevor Spiteri 2007-05-18 08:39:24 UTC
Created attachment 154979 [details]
Liberation Sans dot accents not aligned with i dot

Comment 2 Trevor Spiteri 2007-05-18 08:40:34 UTC
Created attachment 154980 [details]
Liberation Serif dot accents not aligned with i dot

Comment 3 Trevor Spiteri 2007-05-18 08:41:20 UTC
Created attachment 154981 [details]
Liberation Mono dot accents not aligned with i dot

Comment 5 Caius Chance 2007-11-01 00:12:58 UTC
Currently, Liberation Fonts modification is not authorized except by their
manufacturer.

This bug is tracked by bug# 304441 for prompting to the attention of Ascender.

Comment 6 Caius Chance 2008-01-23 05:56:17 UTC
After source update via bug#428596, the bug still able to be reproduced:

Comment 7 Caius Chance 2008-01-23 05:59:03 UTC
Created attachment 292598 [details]
proof 1/3

Comment 8 Caius Chance 2008-01-23 05:59:19 UTC
Created attachment 292599 [details]
proof 2/3

Comment 9 Caius Chance 2008-01-23 05:59:38 UTC
Created attachment 292600 [details]
proof 3/3

Comment 10 Caius Chance 2008-03-25 03:20:29 UTC
According to the testing, the issue had been fixed.

You may feel the dots are still no aligned on the following attached pictures.
However, they are 'illusions' of human eyes. This could be proved with dragging
a horizontal lines to measure by photo editing softwares like Photoshop (r) or GIMP.

The latest version of font will be updated on rawhide very soon.

Comment 11 Caius Chance 2008-03-25 03:21:21 UTC
Created attachment 298967 [details]
Test result pictures - serif.

Comment 12 Caius Chance 2008-03-25 03:21:33 UTC
Created attachment 298968 [details]
Test result pictures - sans.

Comment 13 Caius Chance 2008-03-25 03:21:52 UTC
Created attachment 298969 [details]
Test result pictures - mono.

Comment 14 Caius Chance 2008-03-25 03:22:30 UTC
Created attachment 298970 [details]
Revised fonts.

Comment 15 Caius Chance 2008-03-25 03:23:10 UTC
Bulit on rawhide.

Comment 16 Alexei Podtelezhnikov 2008-04-01 03:45:56 UTC
Wow! This issue was considered worthy of attention and a fix in Liberation 
fonts. The dots are all other the place in DejaVu Serif and Sans. DajaVu 
maintainers are aware but are not making a "decision", aka procrastinating.

See bug 439964 


Note You need to log in before you can comment on or make changes to this bug.