Bug 240591 - X server crash (VESA)
X server crash (VESA)
Status: CLOSED DUPLICATE of bug 241491
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-05-18 12:44 EDT by Onno Witvliet
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-04 11:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg.0.log (91.75 KB, text/plain)
2007-05-18 12:44 EDT, Onno Witvliet
no flags Details
xorg.conf file (852 bytes, application/octet-stream)
2007-05-18 12:45 EDT, Onno Witvliet
no flags Details
Xorg.0.log with glibc version 2.5.90-21 (99.64 KB, application/octet-stream)
2007-05-23 14:03 EDT, Onno Witvliet
no flags Details

  None (edit)
Description Onno Witvliet 2007-05-18 12:44:42 EDT
Description of problem:

I'm running Fedora 7T4 (on a HP Compaq nc8430). After the latest batch of yum
development updates, my X server crashes on startup with the following backtrace:

0: /usr/bin/Xorg(xf86SigHandler+0x6d) [0x47f5ed]
1: /lib64/libc.so.6 [0x2aaaab17f620]
2: /usr/lib64/xorg/modules/drivers//vesa_drv.so [0x2aaaac81c2c1]
3: /usr/bin/Xorg(InitOutput+0x9ad) [0x46320d]
4: /usr/bin/Xorg(main+0x275) [0x433e65]
5: /lib64/libc.so.6(__libc_start_main+0xf4) [0x2aaaab16caa4]
6: /usr/bin/Xorg(FontFileCompleteXLFD+0x231) [0x433319]

Fatal server error:
Caught signal 11.  Server aborting

Additional info:
The machine has an ATI Radeon Mobility x1600 video card.

X server worked with the f7t4 release software
Comment 1 Onno Witvliet 2007-05-18 12:44:42 EDT
Created attachment 155013 [details]
Comment 2 Onno Witvliet 2007-05-18 12:45:43 EDT
Created attachment 155014 [details]
xorg.conf file
Comment 3 Onno Witvliet 2007-05-23 14:03:04 EDT
Created attachment 155282 [details]
Xorg.0.log with glibc version 2.5.90-21

I've downgraded the glibc to the original F7T4 version (2.5.90-21). The X
server no longer crashes, but just stops with:

FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing

I hope this helps
Comment 4 Matěj Cepl 2007-05-26 10:53:35 EDT
Probably DUP of bug 231006 ? There is something screwed up about this card. We
will investigate.
Comment 5 Adam Jackson 2007-05-26 14:26:58 EDT
Yeah, think it is a dup.  Really wish I knew how to reproduce this.

*** This bug has been marked as a duplicate of 231006 ***
Comment 6 Adam Jackson 2007-05-26 14:28:23 EDT
On second thought, no.
Comment 7 Adam Jackson 2007-06-04 11:34:14 EDT

*** This bug has been marked as a duplicate of 241491 ***

Note You need to log in before you can comment on or make changes to this bug.