Bug 240593 - dupe errata mail deluges to the same account
dupe errata mail deluges to the same account
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Corey Welton
:
Depends On:
Blocks: 173427
  Show dependency treegraph
 
Reported: 2007-05-18 13:04 EDT by Máirín Duffy
Modified: 2007-10-23 21:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 23:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2007-05-18 13:04:15 EDT
+++ This bug was initially created as a clone of Bug #240382 +++

Description of problem:

not long after the upgrade to 5.0.1 in hosted today, a customer received 107
errata emails about the rhn-yum-plugin erratum that was released today
(https://rhn.redhat.com/rhn/errata/details/Details.do?eid=5689) 

funny thing is that 107 systems are listed as being affected in the system
summary in the email. 107 systems listed in 107 emails. each list of systems is
the same across emails.

similarly another customer under the same org received 8 emails for the 8
systems that were affected by the same erratum.

I will attach one of the emails with full headers from the 107-email erratum
deluge mentioned above in a private comment.

-- Additional comment from duffy@redhat.com on 2007-05-16 17:55 EST --
note: each email is sent to the same login, each email is re: the same erratum,
and each email contains the same systems in the affected systems list.

Customer reports other accounts that received similar dupe errata emails, only
of the rhn-yum-plugin erratum.

customer reports rhn-yum-plugin erratum is the only one they've received emails
for. other applicable errata have been released yet no emails received on them.

-- Additional comment from duffy@redhat.com on 2007-05-17 15:57 EST --
as of ~3pm eastern today, the rhn-yum-errata plugin alert was resent (only one
email!) plus alerts for other errata as well. attaching a copy of one of this
batch of more correct emails.

-- Additional comment from duffy@redhat.com on 2007-05-17 15:59 EST --
Created an attachment (id=154953)
email that was sent out today, only one copy per errata of this batch was
received

-- Additional comment from morazi@redhat.com on 2007-05-18 09:28 EST --
The first attachment is from taskomatic from a task that was inadvertantly
re-enabled by a production push (RHN 501 hosted).  The second attachment
includes a similarly worded email that is sent out by a python script that is
run by production operations and produces the correct output.

I worked with production operations to disable the task that was erroneously
sending out multiple emails (5-17-2007) and have turned that off in the
configuration files so it doesn't inadvertantly get re-enabled during the next
production push.

-- Additional comment from bretm@redhat.com on 2007-05-18 09:51 EST --
Do we still need this bug open then, or can we close this out as CLOSED
CURRENTRELEASE?  Is there a code change we feel is necessary in rhn502 for this?
Comment 3 Mike McCune 2007-05-18 14:16:26 EDT
yuck.  will move this onto 500s-must
Comment 6 Corey Welton 2007-05-30 13:39:55 EDT
QA Verified - for an errata which affected six systems but to which were
registered to one user, only one errata came through the email:

[...]
There are 6 affected systems registered in 'Your RHN' (only systems for
which you have explicitly enabled Errata Alerts are shown).



System                          Operating System
------------------------------- ---------------------------------------------
fjs-0-07.rhndev.redhat.com
rlx-0-10.rhndev.redhat.com
dhcp77-127.rhndev.redhat.com
dhcp77-127.rhndev.redhat.com_preethi_annie_thomas
dhcp77-229.rhndev.redhat.com
test02-vmx.dom0
Comment 7 Brandon Perkins 2007-06-25 23:12:04 EDT
Closed for Satellite 500 Release.

Note You need to log in before you can comment on or make changes to this bug.