Bug 240625 - boot images from 20070518 fail with ImportError
Summary: boot images from 20070518 fail with ImportError
Status: CLOSED DUPLICATE of bug 240629
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-18 22:23 UTC by Michal Jaegermann
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-19 05:17:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2007-05-18 22:23:03 UTC
Description of problem:

An attempt to boot (tried "rescue") using images posted on
20070518 results in a traceback which ends up with

ImportError: No modules named _sha256.

This comes from line 34 of /usr/lib64/python2.5/hashlib.py
imported in turn by urllib2.

Unfortunately most of a traceback is scrolled off a screen
by "you may safely reboot your system" message and everything
is already killed so no access to logs.

(Tried to confirm that bug 230948 is indeed gone, but no such luck.)

Comment 1 Will Woods 2007-05-19 05:17:19 UTC

*** This bug has been marked as a duplicate of 240629 ***

Comment 2 Gerrit Huizenga 2007-05-20 03:08:58 UTC
I noticed that this occurred on an FC7 yum update - it looks like possibly
python is misconfigured.  The output (note this is manually copied - the FC7
system is without an X11 environment at the moment for either this or some other
reason that I haven't looked into):

There was a problem importing one of the Python modules
required to run yum.  The error leading to this problem was:

   No module named _sha256

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.5 (r25:51908, Apr 10 2007, 10:27:40)
[GCC 4.1.2 20070403 (Red Hat 4.1.2-8)]

Sounds like very similar root cause at least.


Note You need to log in before you can comment on or make changes to this bug.