Bug 240629 - anaconda traceback with _sha256 module on rawhide install
anaconda traceback with _sha256 module on rawhide install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
: 240625 240657 240827 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-05-18 19:35 EDT by John Poelstra
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 15:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (1.12 MB, image/jpeg)
2007-05-18 19:35 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2007-05-18 19:35:54 EDT
Description of problem:
Attempting to install latest rawhide PPC and getting anaconda traceback and
error message of "No module named _sha256"

See attached screen print.

Version-Release number of selected component (if applicable):

cat .treeinfo 
[general]
family = Fedora
timestamp = 1179510412.46
variant = 
totaldiscs = 1
version = development
discnum = 1
packagedir = Fedora
arch = ppc

[images-ppc64]
kernel = ppc/ppc64/vmlinuz
initrd = ppc/ppc64/ramdisk.image.gz
zimage = images/netboot/ppc64.img

[images-ppc]
kernel = ppc/ppc32/vmlinuz
initrd = ppc/ppc32/ramdisk.image.gz
zimage = images/netboot/ppc32.img


From the tree:
anaconda-11.2.0.60-1.ppc.rpm
anaconda-runtime-11.2.0.60-1.ppc.rpm


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Poelstra 2007-05-18 19:35:55 EDT
Created attachment 155037 [details]
traceback
Comment 2 Michal Jaegermann 2007-05-19 01:08:53 EDT
See also bug 240625.  That one from x86_64.
Comment 3 Will Woods 2007-05-19 01:17:21 EDT
*** Bug 240625 has been marked as a duplicate of this bug. ***
Comment 4 Will Woods 2007-05-19 01:18:29 EDT
Seen on i386 as well, I think.
Comment 5 Tom Diehl 2007-05-19 09:18:42 EDT
I can confirm that I am seeing this on i386. It is an old dell 2650, happily
running fc5.
Comment 6 Jeremy Katz 2007-05-19 11:44:33 EDT
*** Bug 240657 has been marked as a duplicate of this bug. ***
Comment 7 Bruno Wolff III 2007-05-20 10:05:18 EDT
I saw this on a dual pentium II machine.

Are you guys seeing this on non http installs?
Comment 8 Tom Diehl 2007-05-20 18:45:25 EDT
My install was over nfs.
Comment 9 Jeremy Katz 2007-05-21 08:39:34 EDT
Fixed in anaconda CVS.

What's happening is that krb5-libs (which is a dep of the _hashlib module)
started depending on libkeyutils but we're not pulling libkeyutils into the
second stage.
Comment 10 Jeremy Katz 2007-05-21 15:20:21 EDT
And Jesse verified with a pungi run with the hotrepos
Comment 11 Tom Diehl 2007-05-21 16:14:58 EDT
Will this show up in tomorrows rawhide or do I actually have to get anaconda out
of cvs?
Comment 12 Bruno Wolff III 2007-05-21 16:20:12 EDT
There is a version bump in the changelog for today, so I expect a new version to
be available tomorrow.
Comment 13 Michal Jaegermann 2007-05-21 18:14:51 EDT
Images which showed up with 20070521 updates are still broken.  I tried.
Comment 14 Jeremy Katz 2007-05-22 07:04:17 EDT
*** Bug 240827 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.