Bug 240664 - Manaworld segfaults
Manaworld segfaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: manaworld (Show other bugs)
8
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On: 426746
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-19 13:35 EDT by Samuel Bizien
Modified: 2008-05-21 07:06 EDT (History)
0 users

See Also:
Fixed In Version: 0.6.1-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 07:01:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backtrace from gdb (852 bytes, text/plain)
2007-05-19 13:35 EDT, Samuel Bizien
no flags Details
GDB backtrace, once -debuginfo installed (532 bytes, application/octet-stream)
2007-05-19 13:54 EDT, Samuel Bizien
no flags Details

  None (edit)
Description Samuel Bizien 2007-05-19 13:35:33 EDT
Description of problem:
TMW crashes when I'm clicking "play" button.

Version-Release number of selected component (if applicable): 0.0.22.2 (x86_64)


How reproducible:
Install manaworld.x86_64 (if you have and amd64 processor) and launch tmw: it
crashes when you click on "play".

Steps to Reproduce:
1. # yum install manaworld
2. $ tmw
3. Click on "play" button, when all is downloaded.
  
Actual results:
Segfault.

Expected results:
Working :) .

Additional info: I'm using fedora 6 x86_64. I use the free drivers (from
extras), on an ATI card.
Comment 1 Samuel Bizien 2007-05-19 13:35:33 EDT
Created attachment 155050 [details]
Backtrace from gdb
Comment 2 Wart 2007-05-19 13:39:08 EDT
Can you install the manaworld-debuginfo and guichan-debuginfo packages and
regenerate the backtrace?
Comment 3 Samuel Bizien 2007-05-19 13:54:33 EDT
Created attachment 155051 [details]
GDB backtrace, once -debuginfo installed
Comment 4 Samuel Bizien 2007-05-19 13:54:52 EDT
Sure.

Done.
Comment 5 Wart 2007-05-25 13:59:42 EDT
Thanks for the trace.  I haven't been able to reproduce this on FC6-x86_64 with
a nvidia card and the binary nvidia drivers, or on FC7T4 with an nvidia card and
the free drivers.  Based on the name of the function where it's crashing, it
appears to me that this might be a crash in the mesa-libgl code and/or the free
ati drivers, not by manaworld itself.
Comment 6 Wart 2007-06-11 16:49:03 EDT
FYI: This has been reported upstream by someone who sees the same problem on
Debian:  http://mantis.themanaworld.org/view.php?id=85

I'll watch the upstream bug report and let you know when/if more information
becomes available.
Comment 7 Wart 2007-06-21 14:32:39 EDT
Upstream has a fix for this now.  If I can get a patch from them then I'll fix
this in the current version.  Otherwise you might have to wait for the next
upstream release (which tends to happen pretty often).
Comment 8 Wart 2008-01-02 19:22:56 EST
manaworld 0.0.24 is supposed to have a fix for this.  I've added bug #426746 as
a dependency on this bug.
Comment 9 Wart 2008-01-04 15:46:33 EST
Updating Fedora version to '8' since the problem is known to exist there as well.
Comment 10 Wart 2008-04-05 11:33:00 EDT
This is fixed in Rawhide, and I'll be updating for F-8 and F-7 soon.
Comment 11 Fedora Update System 2008-04-09 14:26:09 EDT
guichan-0.7.1-1.fc8 has been submitted as an update for Fedora 8
Comment 12 Fedora Update System 2008-04-09 14:30:43 EDT
ballz-1.0-3.fc7,compat-guichan06-0.6.1-7.fc7,manaworld-0.0.24-1.fc7,guichan-0.7.1-1.fc7 has been submitted as an update for Fedora 7
Comment 13 Fedora Update System 2008-04-16 23:49:35 EDT
compat-guichan06-0.6.1-7.fc8, ballz-1.0-3.fc8, guichan-0.7.1-1.fc8, manaworld-0.0.24-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compat-guichan06 ballz guichan manaworld'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3065
Comment 14 Fedora Update System 2008-05-21 07:01:45 EDT
compat-guichan06-0.6.1-7.fc8, ballz-1.0-3.fc8, guichan-0.7.1-1.fc8, manaworld-0.0.24-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-05-21 07:06:37 EDT
ballz-1.0-3.fc7, guichan-0.7.1-1.fc7, manaworld-0.0.24-1.fc7, compat-guichan06-0.6.1-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.