Bug 240668 - F7T4 : Unable to install on existing LVM : 1 PV of 2 detected
F7T4 : Unable to install on existing LVM : 1 PV of 2 detected
Status: CLOSED DUPLICATE of bug 243048
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Depends On:
  Show dependency treegraph
Reported: 2007-05-19 14:16 EDT by Remi Collet
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-25 13:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2007-05-19 14:16:53 EDT
I have 2 x 250 Gb hard disk. 1 PV on each.

My VG is about 500 Gb, with 200 Free

Anaconda detect my VG but only 1 PV.

So for anaconda :
Total space : 250 Gb
Used space : 300 Gb
Free space : -50 Gb

I can't create ou modify existing LV.
So installation is not possible. 

Comment 1 Remi Collet 2007-05-20 03:32:41 EDT

Reading the anaconda sources, i see that it get le "pvlist" from partition table
rather than from "pvscan" result.

After changing the partition type to "LVM PV" using fdisk, installation works fine.

Comment 2 Robert Story 2007-06-05 22:01:43 EDT
I had a similar issue trying to install F7 to an existing LVM group from a FC5
install. Every time I tried to do anything related with LVM, I got an 'not
enough physical volumes' error. This was a ppc machine, so no fdisk. But using
parted to set the lvm flag on existing partitions worked.
Comment 3 Red Hat Bugzilla 2007-06-11 23:55:19 EDT
requested by Jams Antill
Comment 4 Jeremy Katz 2007-06-25 13:20:14 EDT

*** This bug has been marked as a duplicate of 243048 ***

Note You need to log in before you can comment on or make changes to this bug.