Bug 243048 - LVM partition cannot be edited during "Create custom layout" install
Summary: LVM partition cannot be edited during "Create custom layout" install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
: 240668 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-07 01:14 UTC by Jerry Amundson
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 21:50:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jerry Amundson 2007-06-07 01:14:34 UTC
Description of problem:
Installing from F7 KDE i686 LiveCD to LVM PV. Selected "Create custom layout",
edit /dev/sda1 for /boot (preserve), select VolGroup00/LogVol02, then Edit.
Window pops up "Not enough physical volumes", stating "At least one unused
physical volume partition....."

Version-Release number of selected component (if applicable):


How reproducible:
Once, so far.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Edit the LV for / in a multiboot grub system.

Additional info:

Comment 1 Jerry Amundson 2007-06-07 03:36:32 UTC
Hmm. On my Opteron server, I'm able to edit lvm partitions as I would expect -
not sure what differences to look for... server has several vg's over two 160 GB
SATA disks (Vendor: ATA       Model: ST3160812AS), whereas the desktop system
(AMD Athlon(tm) XP 1900+) has a single vg/hd (Model=WDC WD400BB-00FJA0).

Comment 2 Jerry Amundson 2007-06-09 05:36:33 UTC
Simple enough work-around : set the partition type to 8e (Linux LVM). The
partition type had been 83 (Linux), so parted thinks no lvm partitions are
available, even though lvm had already activated the volume group just fine and
presented the partitions to me for the custom layout.
I think a better solution would be consistency - surely I should be able to edit
the custom layout that anaconda itself presented to me....

Comment 3 Jeremy Katz 2007-06-25 17:20:21 UTC
*** Bug 240668 has been marked as a duplicate of this bug. ***

Comment 4 David Cantrell 2007-08-23 21:50:10 UTC
I've just tested this on F-8 Test 1 and it's working fine.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.