Bug 240718 - Missing dependency: dbus should require the gdm package
Summary: Missing dependency: dbus should require the gdm package
Status: CLOSED DUPLICATE of bug 238783
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 03:18 UTC by Robert Brown
Modified: 2013-03-06 03:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 02:23:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Brown 2007-05-21 03:18:53 UTC
Description of problem:
There is a missing package dependency. 

If you have dbus installed and /etc/init.d/messagebus service enabled, when it
starts it expects the user "gdm" to exist since it is explicitly referenced in
/etc/dbus-1/system.d/ConsoleKit.conf. If the gdm package is not installed, the
gdm user is not installed and the service throws out a warning/error when starting.

If you want to replicate, install a system with dbus but without gdm. 

The easy fix is to require the gdm package when dbus is installed and used.


Version-Release number of selected component (if applicable):
This was tested with the latest test release of FC7 test 4.

How reproducible:
Easy. Install dbus without gdm and watch the error show up.

Steps to Reproduce:
1. See above.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Robert Brown 2007-05-21 06:34:11 UTC
As an FYI, I started with FC3 and have been upgrading to FC4, FC5, FC6, and now
the test4 release of FC7. If the gdm user is added in FC7 by default regardless
of package install this issue may never have come up, but I intentionally remove
as many packages as possible and gdm was one that left me in the FC3 days. 

The dependency of dbus to gdm would still fix the problem for those of us who
upgrade over time. 

Comment 2 Matthias Clasen 2007-05-22 02:23:10 UTC

*** This bug has been marked as a duplicate of 238783 ***


Note You need to log in before you can comment on or make changes to this bug.