Bug 240824 - Music Applet only appears for first X session
Summary: Music Applet only appears for first X session
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applet-music   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 301321 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-22 03:47 UTC by Peter Gordon
Modified: 2007-12-14 16:49 UTC (History)
1 user (show)

Fixed In Version: gnome-applet-music-2.2.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 16:49:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Gordon 2007-05-22 03:47:11 UTC
Description of problem:
Hmm... For some reason, Music Applet shows up only for the first X session. If
the X session is ended too abruptly (such as X crashing or the like), then it
simply never shows up in the panel again. Adding it to the panel does not make
it reappear; though with the next reboot it does show the two instances.

I'll need to investigate this further and look through the BZR log; perhaps a
recent commit has fixed this upstream which I can simply backport as needed.


Version-Release number of selected component (if applicable):
gnome-applet-music-2.1.0-2.fc7.x86_64


How reproducible:
Every time, apparently.


Steps to Reproduce:
1. Add Music Applet to the GNOME panel.
2. Make X crash or end abruptly somehow (Ctrl+Alt+Backspace is a good method!
^_^); then login again.
3. ???
4. Profit!!
  
Actual results:
The Music Applet should show on the panel at all times.

Expected results:
It shows up only for the first session.

Comment 1 Peter Gordon 2007-05-22 04:15:01 UTC
If I run the applet from the CLI before adding it to the panel, it gives me the
following errors:

$ /usr/libexec/music-applet 
DEBUG: GConf root is /apps/panel/applets/applet_19/prefs
Failed to open module at
/usr/lib/python2.5/site-packages/musicapplet/plugins/__init__.pyc: 'module'
object has no attribute 'INFO'
Failed to open module at
/usr/lib/python2.5/site-packages/musicapplet/plugins/__init__.py: 'module'
object has no attribute 'INFO'
Failed to open module at
/usr/lib/python2.5/site-packages/musicapplet/plugins/__init__.pyo: 'module'
object has no attribute 'INFO'
Failed to scan /home/peter/.gnome2/music-applet/plugins: [Errno 2] No such file
or directory: '/home/peter/.gnome2/music-applet/plugins'


Comment 2 Peter Gordon 2007-07-28 09:46:39 UTC
Still not fixed in 2.2.0. Hmm. 

Comment 3 Steve Fox 2007-09-24 14:44:02 UTC
*** Bug 301321 has been marked as a duplicate of this bug. ***

Comment 4 Steve Fox 2007-09-24 14:45:00 UTC
I see this same problem without crashing X. I just had logged out, then logged
back in. Rebooting allowed the applet to load (had several copies running :)

Comment 5 Peter Gordon 2007-11-04 04:25:46 UTC
This is fixed in Rawhide/F8. Not sure exactly if it was some X update or 2.2.1
of music-applet; but I'm no longer seeing this issue (having crashed X
intentionally about four times, the applet loads and runs properly after each).
2.2.1 is in the update queue for F-7 and F-8. 

Please reopen this if you are still experience the bug with further details. Thanks.

Comment 6 Peter Gordon 2007-11-16 09:10:49 UTC
Gaah; just crashed X again and Music Applet went with it. Need to dig into this
much farther, it seems. :(

Comment 7 Peter Gordon 2007-11-16 09:11:32 UTC
(In reply to comment #6)
> Gaah; just crashed X again and Music Applet went with it. Need to dig into this
> much farther, it seems. :(

I should note, this is on F-8. I don't believe rawhide users should experience
any similar issues any longer. 

Comment 8 Peter Gordon 2007-12-14 09:07:35 UTC
Steve, do you still experience this issue with updated packages? I'm not sure if
it's the 2.2.1 update or an X update or whatnot, but this seems to have been
fixed somewhere in the past week or so. I'm no longer experiencing this, personally.

Thanks. 

Comment 9 Steve Fox 2007-12-14 16:49:50 UTC
Looks good now. Thanks!


Note You need to log in before you can comment on or make changes to this bug.