Bug 240866 - USB keyboard not working with grub selection
USB keyboard not working with grub selection
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: 300331 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-05-22 10:57 EDT by Slobodan Sredojevic
Modified: 2009-05-04 21:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-05-04 21:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Slobodan Sredojevic 2007-05-22 10:57:33 EDT
Description of problem:
I have tried rawhide-20070517-i386-Live.iso and noticed that my USB keyboard is
not working when presented with bootloader choice.

Keyboard is dead - can't make selection with arrows and led doesn't blink when
capslock is pressed. Waiting for 59 sec timeout helps as it continue with first
item (Run from image). After boot is over and in Gnome environment, keyboard is
alive again.

It is IBM Ultranav USB keyboard:
Motherboard is FIC VC15 (Intel 845D chipset), supports USB 1.1 only.

lspci grep for this system gives:

00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 05)
(prog-if 00 [UHCI])
        Subsystem: FIRST INTERNATIONAL Computer Inc Unknown device 900e
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at b000 [size=32]

00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 05)
(prog-if 00 [UHCI])
        Subsystem: FIRST INTERNATIONAL Computer Inc Unknown device 900e
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at b800 [size=32]

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Put the LiveCD into the tray and boot
Actual results:
User can't make selection from choices grub presents as keyboard is not operational

Expected results:
Keyboard is working - for this stage also

Additional info:
This problem never happened earlier for this machine for any RedHat, Fedora or
other product, this is regression for me FC7 introduce.
Noticed https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192329 so I'll try
BIOS options but this rawhide relaese is the first among many distros this
problem occurs.
Comment 1 Slobodan Sredojevic 2007-05-27 06:35:55 EDT
Not fixed in Fedora-7-Live-i386-RC2 , checked a minute ago.
Comment 2 Luis Felipe Marzagao 2008-01-06 19:38:28 EST
Same problema here: Dell OptPlex GX620, BIOS version: A11

It happens with F8 (final realease) both install DVD and LiveCD.
Comment 3 Bug Zapper 2008-05-13 22:55:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 4 Dean Mander 2008-05-14 09:53:40 EDT
confirmation: problem still apparent on F-9.
Comment 5 petrosyan 2008-06-04 10:44:29 EDT
*** Bug 300331 has been marked as a duplicate of this bug. ***
Comment 6 Steven Moix 2008-06-20 13:36:11 EDT
Same problem on F9 on a Mac Mini Core 2 Duo, the USB keyboard starts working as
soon as anaconda starts but doesn't respond in GRUB. The same keyboard works
fine in the same situation on another computer. So I guess that it's purely
related to Apple's emulated BIOS (version from OSX 10.5.3) which doesn't seem to
support this.

00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Intel Corporation Unknown device 7270
        Flags: bus master, medium devsel, latency 0, IRQ 19
        I/O ports at 2080 [size=32]
        Kernel driver in use: uhci_hcd
        Kernel modules: uhci-hcd
Comment 7 cornel panceac 2008-08-06 00:55:25 EDT
same thing in f10 alpha i686 live cd: in three attempts, the third no longer provides keyboard control to grub menu. keyboard is microsoft, usb connected.gigabyte motherboard, mcp55 chipset. similar behaviour i've noticed on previous installed f10-x86_64-rawhide, with a logitech keyboard.
Comment 8 Linus Walleij 2008-12-07 12:19:06 EST
Bug hits me on this Dell XPS201 making it totally impossible to install
this system with F10, since I need to pass in boot options to the GRUB
on the install CD (waiting for it to time out won't help me).

The GRUB installed by the OS works fine, from an old F9 installation,
but the GRUB on the install CD (DVD or netinstall) cannot
handle the USB keyboard. Is the installer using an old version of

I read a hint somewhere about setting the keyboard to "legacy mode" in
the BIOS, but this machines doesn't even have a "legacy mode" so no
luck with that.
Comment 9 Jeremy Katz 2009-05-04 10:49:34 EDT
The live images and boot.iso are all using isolinux on the CD, not grub.  And I know there are some changes in the version of syslinux destined for F11 -- are you still seeing problems with F11 preview?
Comment 10 Luis Felipe Marzagao 2009-05-04 20:17:29 EDT
Nice! For the first time, my Dell keyboard has worked during boot screen with F11 Preview! nice work! :)

Note You need to log in before you can comment on or make changes to this bug.