Bug 240956 - XV and GL break under Beryl with Intel i945 graphics device
XV and GL break under Beryl with Intel i945 graphics device
Status: CLOSED DUPLICATE of bug 239125
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-23 09:01 EDT by Steve Hill
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 09:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg config file (823 bytes, text/plain)
2007-06-11 09:25 EDT, Steve Hill
no flags Details
Xorg log file (61.81 KB, text/plain)
2007-06-11 09:26 EDT, Steve Hill
no flags Details
Xorg log file for running Xorg with no config file (69.01 KB, text/plain)
2007-06-11 09:42 EDT, Steve Hill
no flags Details

  None (edit)
Description Steve Hill 2007-05-23 09:01:54 EDT
Description of problem:
I am running Beryl on an Intel 945 integrated graphics chipset.  Trying to play
XV video results in "BadAlloc: Insufficient Resource" and Beryl's 3D
transformations (wobbly windows, cube, etc) cause the contents of OpenGL windows
to "stick" to the screen instead of staying inside the window.

Version-Release number of selected component (if applicable):
7.2-6.fc7

How reproducible:
Always

Steps to Reproduce:
1. Run Xorg on an Intel i945 chipset
2. Start beryl-manager
3. Try playing an XV video (e.g. mplayer, vlc, etc) or OpenGL application (glxgears)
  
Actual results:
XV applications bomb immediately with "BadAlloc", the contents of GL windows
doesn't get 3D transformed when doing desktop-cube rotation, wobbly windows, etc.

Expected results:
XV video should work, the contents of GL windows should stay inside the window.

Additional info:
Comment 1 Matěj Cepl 2007-05-30 20:42:04 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Steve Hill 2007-06-11 09:25:48 EDT
Created attachment 156706 [details]
xorg config file
Comment 3 Steve Hill 2007-06-11 09:26:43 EDT
Created attachment 156707 [details]
Xorg log file
Comment 4 Steve Hill 2007-06-11 09:42:50 EDT
Created attachment 156708 [details]
Xorg log file for running Xorg with no config file

I get the same results when running with no Xorg.conf
Comment 5 Steve Hill 2007-06-11 09:43:48 EDT
Example of the failure:

[steve@atlantis hdtv]$ vlc bbc-hd-coast-wales.nuv 
VLC media player 0.8.6b Janus
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  84
  Current serial number in output stream:  85
[steve@atlantis hdtv]$ 

It should be noted that this works fine when not running Beryl.
Comment 7 Adam Jackson 2007-07-27 18:10:28 EDT

*** This bug has been marked as a duplicate of 222262 ***
Comment 8 Steve Hill 2007-07-28 04:31:30 EDT
Is #222262 really the same bug?  It looks quite different and is affecting
completely different hardware.
Comment 9 Juan Pablo Salazar Bertin 2007-08-15 19:39:56 EDT
This is a duplicate of bug #239125
Comment 10 Matěj Cepl 2007-08-16 09:36:09 EDT
sorry, bad duplicate, Juan you are right.

*** This bug has been marked as a duplicate of 239125 ***

Note You need to log in before you can comment on or make changes to this bug.