Bug 241206 - Bugzilla fails to install due to missing dependencies
Bugzilla fails to install due to missing dependencies
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: bugzilla (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
:
Depends On: 241251 242926 242929 242931
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 09:02 EDT by Dawid Zamirski
Modified: 2007-11-26 09:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 09:38:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of yum install bugzilla (11.42 KB, text/plain)
2007-05-24 09:02 EDT, Dawid Zamirski
no flags Details
yum install bugzilla (11.83 KB, text/plain)
2007-06-06 08:58 EDT, Dawid Zamirski
no flags Details
yum install bugzilla with FC6 extras repo (11.69 KB, text/plain)
2007-06-06 09:09 EDT, Dawid Zamirski
no flags Details

  None (edit)
Description Dawid Zamirski 2007-05-24 09:02:37 EDT
Description of problem:
When I attempt to install Bugzilla 3.0, the installation failed due to several
perl dependencies. I've attached yum install bugzilla output.
Comment 1 Dawid Zamirski 2007-05-24 09:02:37 EDT
Created attachment 155338 [details]
Output of yum install bugzilla
Comment 2 John Berninger 2007-05-24 10:17:37 EDT
I've built new packages to address the bugzilla dependencies outstanding here. 
They should be signed and available in public repos shortly.  The dependency
failures against the non-bugzilla packages I cannot resolve; if there are no
more bugzilla dependencies erroring, please feel free to reassign this bug (or
open a new one) against the packages that do still have outstanding unresolved
dependencies.
Comment 3 Dawid Zamirski 2007-05-24 12:36:28 EDT
Ok, I have filled a bug against perl-SOAP-Lite and made this bug depend on it.
I havn't filled a bug for perl-MIME-Lite because it has the same dependency
problem as the bugzilla package (MAIL::Address)
Comment 4 Dawid Zamirski 2007-05-29 15:31:00 EDT
I checked today and this is what's still needed by bugzilla package itself:

Email::MIME::Modifier
MIME::Parser
Template::Stash
Email::MIME::Attachment::Stripper
Template::Config
Email::Reply
Email::MIME
Email::Address
Email::Send
Comment 5 John Berninger 2007-06-05 12:21:31 EDT
The dependencies should now be fixed in EPEL 5 with version 3.0-2
Comment 6 Dawid Zamirski 2007-06-06 08:58:40 EDT
Created attachment 156345 [details]
yum install bugzilla

While perl-Soap-Lite works now, bugzilla itself still needs more perl packages
(see attached yum install bugzilla output). Additionally it would be useful to
have optional packages to enable full bugzilla functionality such as
perl-PatchReader perl-Chart perl-HTML-scrubber etc.
Comment 7 Dawid Zamirski 2007-06-06 09:09:20 EDT
Created attachment 156346 [details]
yum install bugzilla with FC6 extras repo

I have also attached output of yum install bugzilla with Fedora Core 6 Extras
repository enabled in RHEL 5 which works well for me as a temporary solution.
Comment 8 rob 2007-11-15 13:06:27 EST
The following packages required directly or indirectly by bugzilla are
maintained in Fedora by corsepiu, cweyl, or jpo.  I emailed each maintainer on 6
Nov 2007 requesting EPEL 5 branches, but got no response.

Package Change Request
======================
Package Name: [ list of packages enumerated below ]
Updated EPEL Owners: rmyers

perl-Class-Inspector
perl-File-Find-Rule
perl-File-Remove
perl-Font-AFM
perl-HTML-Format
perl-Number-Compare
perl-Params-Util
perl-Params-Validate
perl-Test-ClassAPI
perl-Test-Taint
perl-Text-Glob
perl-Data-OptList
perl-Package-Generator
perl-Sub-Exporter
perl-AppConfig
perl-B-Keywords
perl-Config-Tiny
perl-Devel-Cycle
perl-Email-Address
perl-Email-MessageID
perl-Email-MIME-ContentType
perl-Email-MIME-Encodings
perl-Email-MIME
perl-Email-MIME-Modifier
perl-Email-MIME-ContentType
perl-Email-MIME-Encodings
perl-Email-MIME-Modifier
perl-Email-Simple
perl-File-HomeDir
perl-File-Which
perl-FreezeThaw
perl-GDGraph3d
perl-Hook-LexWrap
perl-Image-Base
perl-Image-Info
perl-Image-Size
perl-Image-Xbm
perl-Image-Xpm
perl-List-MoreUtils
perl-PadWalker
perl-Perl-Critic
perl-Pod-Spell
perl-PPI
perl-String-Format
perl-Test-Differences
perl-Test-Manifest
perl-Test-Memory-Cycle
perl-Test-Object
perl-Test-Perl-Critic
perl-Test-Spelling
perl-Test-SubCalls
perl-TeX-Hyphen
Comment 9 Toshio Ernie Kuratomi 2007-11-15 14:20:10 EST
cvs done.
Comment 10 rob 2007-11-24 00:14:13 EST
All of the dependencies should now be available in epel5 testing.
Comment 11 Juha Tuomala 2007-11-24 03:08:52 EST
When looking at the perl pkg list, I guess this is no-go for el4?
Comment 12 rob 2007-11-26 09:38:42 EST
(In reply to comment #11)
> When looking at the perl pkg list, I guess this is no-go for el4?

this bug is for bugzilla 3.0 and EL5.  i haven't looked at bugzilla 2.22 and EL4.

Note You need to log in before you can comment on or make changes to this bug.