Bug 241375 - yum dependency solving problem with latest kernel update
yum dependency solving problem with latest kernel update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 11:24 EDT by David Kovalsky
Modified: 2014-03-31 19:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 13:00:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2007-05-25 11:24:52 EDT
I'm trying to do a kernel update today on my rawhide, but yum fails with
dependency issues.

[root@kovinek ~]# yum --disablerepo=atrpms --disablerepo=southpark list updates
Loading "installonlyn" plugin
Loading "changelog" plugin
Updated Packages
kernel.i686                              2.6.21-1.3194.fc7      fedora-base
kernel-headers.i386                      2.6.21-1.3194.fc7      fedora-base


[root@kovinek ~]# yum --disablerepo=atrpms --disablerepo=southpark update
Loading "installonlyn" plugin
Loading "changelog" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:2.6.21-1.3194.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.21-1.3194.fc7 set to be updated
filelists.sqlite.bz2      100% |=========================| 6.4 MB    00:14
filelists.sqlite.bz2      100% |=========================| 2.5 MB    00:00
filelists.xml.gz          100% |=========================| 1.4 kB    00:00
filelists.xml.gz          100% |=========================|  466 B    00:00
filelists.xml.gz          100% |=========================|  46 kB    00:00
filelists.xml.gz          100% |=========================|  561 B    00:00
filelists.xml.gz          100% |=========================| 4.4 kB    00:00
filelists.xml.gz          100% |=========================|  26 kB    00:00
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3189.fc7 for package:
ieee80211-kmdl-2.6.21-1.3189.fc7
--> Processing Dependency: /boot/vmlinuz-2.6.21-1.3189.fc7 for package:
ipw3945-kmdl-2.6.21-1.3189.fc7
--> Finished Dependency Resolution
Error: Missing Dependency: /boot/vmlinuz-2.6.21-1.3189.fc7 is needed by package
ieee80211-kmdl-2.6.21-1.3189.fc7
Error: Missing Dependency: /boot/vmlinuz-2.6.21-1.3189.fc7 is needed by package
ipw3945-kmdl-2.6.21-1.3189.fc7

This is weird because I'm trying to update (install) kernel 2.6.21-1.3194.fc7
and it screams about dependencies for 2.6.21-1.3189.fc7

[root@kovinek ~]# yum list installed kernel\* ipw3945-kmdl\* ieee80211-kmdl\*
yum rpm
Loading "installonlyn" plugin
Loading "changelog" plugin
Installed Packages
ieee80211-kmdl-2.6.21-1.3175.fc7.i686    1.2.16-18.fc6.93       installed
ieee80211-kmdl-2.6.21-1.3189.fc7.i686    1.2.16-18.fc6.93       installed
ipw3945-kmdl-2.6.21-1.3175.fc7.i686      1.2.0-18.3.fc6.93      installed
ipw3945-kmdl-2.6.21-1.3189.fc7.i686      1.2.0-18.3.fc6.93      installed
kernel.i686                              2.6.21-1.3175.fc7      installed
kernel.i686                              2.6.21-1.3189.fc7      installed
kernel-headers.i386                      2.6.21-1.3189.fc7      installed
kernel-xen.i686                          2.6.20-2925.9.fc7      installed
rpm.i386                                 4.4.2-46.fc7           installed
yum.noarch                               3.2.0-1.fc7            installed

And yes, I did a `yum clean all' in the beginning :)

FTR: the ipw3945-kmdl and ieee80211-kmdl are from atrpms repo. I'm running
rawhide on this machine for a few weeks now and updated kernel & the modules
several times, but I've never seen this happen before.
Comment 1 Jesse Keating 2007-06-13 13:00:28 EDT
It's saying that your installed kmdl packages require a kernel your update is
set to remove.  This is correct.  It's the packages you already have installed
that will be broken by the upgrade.

Note You need to log in before you can comment on or make changes to this bug.