Bug 241485 - Bug on bootup when using 2.6.21-1.3194.fc7: softirq.c:138
Summary: Bug on bootup when using 2.6.21-1.3194.fc7: softirq.c:138
Status: CLOSED DUPLICATE of bug 240982
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-26 14:48 UTC by Stewart Adam
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-26 16:41:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stewart Adam 2007-05-26 14:48:13 UTC
Description of problem:
This is in the /var/log/messages file every startup:

May 26 10:33:35 MyHost kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
May 26 10:33:35 MyHost kernel: [<c042b0cf>] local_bh_enable+0x45/0x92
May 26 10:33:35 MyHost kernel: [<c06002bd>] cond_resched_softirq+0x2c/0x42
May 26 10:33:35 MyHost kernel: [<c059adf3>] release_sock+0x4f/0x9d
May 26 10:33:35 MyHost kernel: [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
May 26 10:33:35 MyHost kernel: [<c04e7350>] copy_to_user+0x3c/0x50
May 26 10:33:35 MyHost kernel: [<c059f285>] memcpy_toiovec+0x27/0x4a
May 26 10:33:35 MyHost kernel: [<c059ddb8>] __kfree_skb+0xb5/0x113
May 26 10:33:35 MyHost kernel: [<c06016f4>] _spin_lock_bh+0x8/0x18
May 26 10:33:35 MyHost kernel: [<c05dec95>] inet_sendmsg+0x3b/0x45
May 26 10:33:35 MyHost kernel: [<c0598731>] sock_aio_write+0xf6/0x102
May 26 10:33:35 MyHost kernel: [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
May 26 10:33:35 MyHost kernel: [<c0436e71>] autoremove_wake_function+0x0/0x35
May 26 10:33:35 MyHost kernel: [<c04e7100>] copy_from_user+0x3a/0x66
May 26 10:33:35 MyHost kernel: [<c04752a5>] rw_copy_check_uvector+0x5c/0xb0
May 26 10:33:35 MyHost kernel: [<c0475b33>] do_readv_writev+0xbc/0x187
May 26 10:33:35 MyHost kernel: [<c059863b>] sock_aio_write+0x0/0x102
May 26 10:33:35 MyHost kernel: [<c059a7dc>] sock_common_setsockopt+0x1d/0x22
May 26 10:33:35 MyHost kernel: [<c0475c3b>] vfs_writev+0x3d/0x48
May 26 10:33:35 MyHost kernel: [<c04760a4>] sys_writev+0x41/0x95
May 26 10:33:35 MyHost kernel: [<c0404f70>] syscall_call+0x7/0xb
May 26 10:33:35 MyHost kernel: =======================


Version-Release number of selected component (if applicable):
2.6.21-1.3194.fc7

How reproducible:
Always

Steps to Reproduce:
1. Boot using the kernel 2.6.21-1.3194.fc7
  
Actual results:
Nothing seems wrong to be going wrong, but something is crashing...

Expected results:
There is no bug on bootup

Additional info:

Comment 1 Stewart Adam 2007-05-26 16:41:22 UTC
Oops, my bad - Already reported in #240982

*** This bug has been marked as a duplicate of 240982 ***


Note You need to log in before you can comment on or make changes to this bug.